Dunst Autostart

I'm using Manjaro i3 Community Edition.
Dunst always autostarts but I can't seem to find the RC or config file that is autostarting dunst. It definitely is not the i3 config file. So I'm wondering, could it be autostarted by the dbus daemon? Please let me know if any log or output would be useful. Thx in advance!

cat ~/.config/i3/config  | grep -i  dunst

Just to double check. Not running i3 anymore.
Other places to check .profile .bashrc etc.

So if you have the silver searcher installed:

ag  dunst --depth=0 --hidden

will find any references if run in your ~/

https://wiki.archlinux.org/index.php/Dunst my help.

1 Like

Thanks for the reply xircon!
The only reference to "dunst" is in my i3 config, but its just a keybind to restart dunst originating from the default i3 config of Manjaro i3 Community Edition.

Output for grep search in i3 config: bindsym $mod+Shift+d --release exec "killall dunst; exec notify-send 'restart dunst'

Other than silver searcher I also tried searching my home directory with grep, and I only found another reference to "dunst" from my fish shell history.

Grep search: grep -rnw "/home/username/" -e "dunst"
Output: /home/username/.local/share/fish/fish_history:1331:- cmd: ag dunst --depth=0 --hidden

Thanks for the reply anyhow.

Then it is time to call in @oberon......

1 Like

Are there any service files listed in /usr/share/dbus-1/services that have notification or dunst in the title?

Services can be launched there w d-bus, https://wiki.archlinux.org/index.php/Desktop_notifications#Notification_servers

1 Like

dunst is launched as a systemd service:
usr/lib/systemd/user/dunst.service

3 Likes

Thank you three! I found the service file in /usr/lib/systemd/user/dunst.service but how do I check if that service is enable? Sorry I'm kinda nub at this :laughing:

I ran systemctl --user status dunst and this is the output:
● dunst.service - Dunst notification daemon Loaded: loaded (/usr/lib/systemd/user/dunst.service; disabl> Active: inactive (dead) Docs: man:dunst(1)

Thanks @aircly

[D-BUS Service]
Name=org.freedesktop.Notifications
Exec=/usr/bin/dunst
SystemdService=dunst.service

So it it's being launched by d-bus how do I check it's status?
Because I tried checking it with systemctl and it says that it's "disabled, inactive (dead)"
Thank you buddy!

This is my service status:

systemctl status --user dunst

dunst.service - Dunst notification daemon
     Loaded: loaded (/usr/lib/systemd/user/dunst.service; disabled; vendor preset: en>
     Active: active (running) since Tue 2020-05-12 07:18:45 CEST; 13min ago
       Docs: man:dunst(1)
   Main PID: 1150 (dunst)
     CGroup: /user.slice/user-1000.slice/user@1000.service/dunst.service
             └─1150 /usr/bin/dunst

Mai 12 07:18:45 np900x4d systemd[993]: Starting Dunst notification daemon...
Mai 12 07:18:45 np900x4d systemd[993]: Started Dunst notification daemon.
Mai 12 07:18:55 np900x4d dunst[1150]: WARNING: No icon found in path: 'nm-signal-100'
lines 1-11/11 (END)

And this is the content of my dunst.service

less /usr/lib/systemd/user/dunst.service

[Unit]
Description=Dunst notification daemon
Documentation=man:dunst(1)
PartOf=graphical-session.target

[Service]
Type=dbus
BusName=org.freedesktop.Notifications
ExecStart=/usr/bin/dunst

[Install]
WantedBy=default.target
1 Like

Rather than change the behavior (even following the arch wiki) I would instead chase down why that service is inactive and fix that first. If the service isn't running, then it probably won't run when launched elsewhere. If the service was enabled it was started with systemd instead of d-bus, in which the maintainer may have a reason for.

With everything running properly is when I would change the way things interact.

Do $sudo systemctl enable dunst and reboot. If its still dead then do $ journalctl -u dunst

1 Like

Thanks for the reply.

@airclay I've tried 2 commands in the past, and these are the outputs:

Command: sudo systemctl enable dunst
Output: Failed to enable unit: Unit file dunst.service does not exist.

Command: systemctl enable --user dunst
Output: Created symlink /home/meekranjer/.config/systemd/user/default.target.wants/dunst.service → /usr/lib/systemd/user/dunst.service.

Follow up after the reboot: (systemctl status --user dunst)
● dunst.service - Dunst notification daemon

  • Loaded: loaded (/usr/lib/systemd/user/dunst.service; enabled; vendor preset: enabled)*
    
  • Active: failed (Result: exit-code) since Wed 2020-05-13 16:22:09 +08; 20s ago*
    
  •   Docs: man:dunst(1)*
    
  • Process: 1029 ExecStart=/usr/bin/dunst (code=exited, status=1/FAILURE)*
  • Main PID: 1029 (code=exited, status=1/FAILURE)*

May 13 16:22:09 DL systemd[1023]: Starting Dunst notification daemon...
May 13 16:22:09 DL systemd[1023]: dunst.service: Main process exited, code=exited, status=1/FAILURE
May 13 16:22:09 DL systemd[1023]: dunst.service: Failed with result 'exit-code'.
May 13 16:22:09 DL systemd[1023]: Failed to start Dunst notification daemon

This is the output for the suggested troubleshooting command: (journalctl -u dunst)
-- Logs begin at Sat 2020-05-02 23:23:19 +08, end at Wed 2020-05-13 16:22:48 +08. --
-- No entries --

At this point if it is too hard to troubleshoot this problem, I'm really fine to just reinstall Manjaro i3. Or not, it really doesn't matter! This isn't a fatal issue and I just noticed this whole dunst thing whilst I was learning Linux. Even if I reinstall I already have my config files in the cloud so its no big hassle. However if any of you are free and won't mind, it would be nice if we could continue this thread so everyone can learn a bit of Linux in the process!
Thank you in advance!

I'll just mark this topic solved. I've reinstalled Manjaro i3 and ran systemctl status --user dunst and it was right there, running.

I've checked my secondary computer and dunst wasn't running too, so I reinstalled Manjaro on there as well. I don't know if these systemctl issues happened because of some configuration I did, or that Manjaro i3 tends to become unstable over time. That won't stop me from using it however, because of the ease of use and efficiency it provides.

I'm fine with doing a clean reinstall every once in a while. Thank you to all of you who replied to this thread previously!

1 Like

Forum kindly sponsored by