Dumped Core problem

Got this error after update:

Process 2314 (warspear-online) of user 1000 dumped core.

                                                      Module linux-vdso.so.1 with build-id 0a3183f4bfd6d18e8697a77f1cac246cfcfc0940
                                                      Module libnss_myhostname.so.2 with build-id 4951b5811470eaf99882e4891f149237b82ca605
                                                      Module libnss_resolve.so.2 with build-id 514ce3b5a709858e5730fa89b486d66f04304431
                                                      Module libnss_mdns4_minimal.so.2 with build-id a6fde528b667185a18aca5be61727fb369423647
                                                      Module libnss_mymachines.so.2 with build-id 0822868ed745fc3713fc9645834e142c6e109cdf
                                                      Module libgpg-error.so.0 with build-id 82524ee3d1c4c2244d7cfdcc1e6eea5f9855f6c6
                                                      Module libgcrypt.so.20 with build-id db45f5d5e0f7af1e77324fea1885f974619ad268
                                                      Module libcap.so.2 with build-id eb6dae97527fc89dbb0d5bb581a15acd02ae9f56
                                                      Module liblz4.so.1 with build-id e63600ab23b2f6997f42fac2fa56e1f02ce159a1
                                                      Module liblzma.so.5 with build-id 8b615460aa230708c5183f16bede67aa0437d95e
                                                      Module libogg.so.0 with build-id ca0cae30a809f10db1f16e54a23b4e5ff7b2c54c
                                                      Module libvorbis.so.0 with build-id ad0a6c1af8f219b4e314090b6e8847223d424cbe
                                                      Module libopus.so.0 with build-id 35fafc4024675e9cfe57c7d50c3965eac6bac358
                                                      Module libFLAC.so.8 with build-id d3c01b1bab8e878ff3928ba64a5817506bad1aa6
                                                      Module libvorbisenc.so.2 with build-id 28ed815b8b1d322e6bf2bfdce4b0af2789b74335
                                                      Module libasyncns.so.0 with build-id 6acff139d56b5139ce5eb50a66c62b215e1d332d
                                                      Module libsystemd.so.0 with build-id c9e19a3f6e503f05f60867b9240c1d59bf6c605e
                                                      Module libsndfile.so.1 with build-id 72d5531e74ed3e9afe49e95e449c40cb8984a258
                                                      Module libdbus-1.so.3 with build-id 74f2ab9c60512f3a93c932c3f627564d42e0b11e
                                                      Module libpulsecommon-15.0.so with build-id 1ff39f66b974fdf20be485f556b48ff4e6c33868
                                                      Module libpulse.so.0 with build-id b145e13bdb30c8327de7882ec9976fab38bc3e4a
                                                      Module librt.so.1 with build-id 4761858b348db8303e872e515aa8d56c046c921c
                                                      Module libdb-5.3.so with build-id 9422fdf20e44ff3d5c58f76ef36be3432c6057c3
                                                      Module libjack.so.0 with build-id cd2c5ca3b195fe16a2cfcda1f5246ea2fc169b5a
                                                      Module libresolv.so.2 with build-id 46ffdf3d477a170314060c26927470d7399bc900
                                                      Module libkeyutils.so.1 with build-id ac405ddd17be10ce538da3211415ee50c8f8df79
                                                      Module libkrb5support.so.0 with build-id adf65240a4d2aba772d7a0772b4d015469934113
                                                      Module libcom_err.so.2 with build-id 358b783c9b3d12ba8248519ea2e7f3da4c4e0297
                                                      Module libk5crypto.so.3 with build-id eb8220b8f36675aac769450be4cb6bb7f97ec38a
                                                      Module libkrb5.so.3 with build-id 72d26767c5cb1097db75a5f5bff88860233c902b


Can’t play this game, it crashes when pressing some keys on the keyboard.

That is a piece of software installed via the AUR.
It probably needs to be rebuilt - but it has also been flagged as out of date and the PKGBUILD itself may need an update before that can work.

AUR (en) - warspear

Actualy I flaged outdated… And I build an updated one from a .deb file.

Still doesn’t work… thats why I dont use linux. Always full of bugs. The game was working fine utill a lots of updates this morning…

… not anymore, I guess :sunglasses:
But that is your choice to make.

I’m not a gamer - but I noticed that there is a steam version of the game, so it should be possible to use that.
I don’t know.

Warspear Online

Maybe you made a mistake there?
… just maybe :wink:

Custom packages is unsupported.

Also custom package scripts on AUR assumes Arch package levels - this cannot be achieved on Manjaro stable branch - you may need to switch to testing or unstable.

I will repeat what has already been said - rebuild the package.

What I can tell you (@WandersonCL ) now is this:
I did pretty much what the PKGBUILD is doing, which is
I downloaded the debian version from the website I linked to - the games own website.


I unpacked that file like the PKGBUILD is doing it

I just did not move it to a system directory (/opt/warspear)
but instead I simply started it from where I unpacked it.

The game runs flawlessly as far as I can tell.

So it appears you indeed did something wrong when you installed it via your own PKGBUILD.

Don’t blame Linux when there is a much more likely source of error
… just saying …

1 Like

Not working

Game start but when you try to type anything it closes

I do not know how the game works but I can use mouse and keyboard just fine in the places I could find where I needed to type something - without learning the game.
Can’t help further.

It may or may not be important:
my system is actually Arch - not Manjaro (which I only run in a VM) - the glibc version on Manjaro stable might be different

It’s the same as Arch on all branches:

Just for you to know, I instaled EndeavourOS and it started working again. Maybe if a reinstaled Manjaro it worked too, but I liked EOS, it has a true lockscreen that don’t kills the runI ning app in the background, like Idle games that I play and when I leave o lock my screen and the game disconnects on manjaro, not in EOS.

I have to came with this dreadful solution, an ugly screensaver with lock option:

The endevour os guys also use xfce4-screensaver as suggested in my original post. Have you tried customizing it before coming to cry about it here?

Did’t find how…

Any custom package is unsupported.

We cannot help you with your issue - you responses are - to say the least - not informative - therefore topic closed - not a Manjaro issue.

Refer the forum rules if in doubt.

1 Like