Dualshock Controller Button mapping issue


I recently bought the new Sony Dualshock (PS5) controller. When I plugged in the device, after reading forums about the great support for the controllers, I noticed that I was having a different experience.

To note, I am having issues with Lutris-based games, and I haven’t tested Steam quite yet. My main game is Rocket League. When entering the game, the controls are all mapped incorrectly. For instance, drive is normally R2, but is instead controlled with the right analog stick.

I have gone through my settings, tried to remap in Manjaro itself, even in games but found nothing. I researched and found that there was a program called sc-controller which supposedly fixes the issue but tried for hours, got nothing.

I know this is a fairly new controller but is anyone aware how I can correct this button mapping issue? Thanks!

I recently setup DualSense to play Diablo II: Resurrected. First try ds360 mentioned in the post, because it is easier, if that doesn’t work try to setup sc-controller with the branch that has DualSense support.