Dual screen not working on new laptop


I recently installed manjaro xfce on my laptop, and when i tried to plug in a second monitor, it wouldnt work, tweaked a few things that i cant correctly remember (it was had something to do with the xorg.conf file) a few days ago and still didnt work so i gave up but recently decided to give it a try again, but this time my display setup was changed.
At the beginning, only my laptop screen was turning on even tho my second screen was detected in display settings, i just couldnt enable it, but now only my second monitor is turning on, and my laptop screen isnt detected anymore in my settings, but i i go on a TTY it uses the laptop screen.

Here’s my config:

  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=822787de-828f-47d3-b5a4-3bb767713102 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Nitro AN515-45 v: V1.08
    serial: <superuser required>
  Mobo: CZ model: Scala_CAS v: V1.08 serial: <superuser required>
    UEFI: Insyde v: 1.08 date: 07/21/2021
  ID-1: BAT1 charge: 56.2 Wh (99.6%) condition: 56.4/57.5 Wh (98.1%)
    volts: 17.5 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
    status: N/A
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1207 high: 1350 min/max: 1200/3200 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1231 2: 1350
    3: 1197 4: 1197 5: 1197 6: 1197 7: 1348 8: 1175 9: 1135 10: 1150 11: 1197
    12: 1197 13: 1197 14: 1198 15: 1163 16: 1197 bogomips: 102241
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q]
    vendor: Acer Incorporated ALI driver: nvidia v: 495.46
    alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:249d
    class-ID: 0300
  Device-2: AMD Cezanne vendor: Acer Incorporated ALI driver: amdgpu
    v: kernel bus-ID: 05:00.0 chip-ID: 1002:1638 class-ID: 0300
  Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 3-3:3
    chip-ID: 0408:a061 class-ID: 0e02
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
    loaded: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
    s-diag: 777mm (30.6")
  Monitor-1: HDMI-0 res: 2560x1440 hz: 144 dpi: 109
    size: 597x336mm (23.5x13.2") diag: 685mm (27")
  Message: Unable to show advanced data. Required tool glxinfo missing.

I guess iGPU is AMD, therefore the laptop screen and dGPU is NVIDIA, therefore the second screen. You need a prime-reverse setup, where nvidia will be the main, but passthrough the screen to the amdgpu… That is the only way to have both screens active with nvidia driver. Just search the forum and say what you have tried. Config file?