Dual monitor setup weird in-between screens edge behaviour

Hello everyone,

Quick hardware/software info:

  • OS: Manjaro
  • Kernel: 5.4.80-2-MANJARO
  • DE: KDE 5.20.4
  • CPU: i5-4460
  • GPU: AMD Radeon R9 380
  • Left monitor: 1366x768 connected via VGA (DVI to VGA adapter)
  • Right monitor: 1920x1080 connected via DVI

inxi -Fazy output:

  Kernel: 5.4.80-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=87746dc8-bc89-476e-9ae9-0764420a6ccb rw quiet amdgpu.dc=0 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASRock model: B85 Anniversary serial: <filter> 
  UEFI: American Megatrends v: P1.40 date: 07/27/2015 
  Info: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP arch: Haswell 
  family: 6 model-id: 3C (60) stepping: 3 microcode: 28 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 25600 
  Speed: 1352 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 1352 2: 2019 
  3: 1545 4: 1569 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Tonga PRO [Radeon R9 285/380] vendor: Gigabyte driver: amdgpu 
  v: kernel bus ID: 01:00.0 chip ID: 1002:6939 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: amdgpu,ati 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 867x285mm (34.1x11.2") 
  s-diag: 913mm (35.9") 
  Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 96 
  size: 510x287mm (20.1x11.3") diag: 585mm (23") 
  Monitor-2: DVI-I-1 res: 1366x768 hz: 60 dpi: 85 size: 410x230mm (16.1x9.1") 
  diag: 470mm (18.5") 
  OpenGL: renderer: AMD Radeon R9 380 Series v: 4.6.13572 Core Profile Context 
  compat-v: 4.6.13572 direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASRock 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-2: AMD Tonga HDMI Audio [Radeon R9 285/380] vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aad8 
  Sound Server: ALSA v: k5.4.80-2-MANJARO 
  Device-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter vendor: ASUSTeK PCE-N10 
  driver: rtl8192ce v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8176 
  IF: wlp3s0 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: c000 bus ID: 05:00.0 
  chip ID: 10ec:8168 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IF-ID-1: br-abbdefd912f4 state: down mac: <filter> 
  IF-ID-2: docker0 state: down mac: <filter> 
  Local Storage: total: 1.20 TiB used: 132.99 GiB (10.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-60WN4A0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: MBR 
  ID-2: /dev/sdb vendor: Western Digital model: WD3200AAJS-60Z0A0 
  size: 298.09 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  serial: <filter> rev: 3E03 scheme: GPT 
  ID-1: / raw size: 297.79 GiB size: 292.12 GiB (98.09%) 
  used: 132.99 GiB (45.5%) fs: ext4 dev: /dev/sdb2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: file size: 16.00 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  System Temperatures: cpu: 45.0 C mobo: N/A gpu: amdgpu temp: 55.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1293 
  Processes: 240 Uptime: 1h 01m Memory: 15.58 GiB used: 3.46 GiB (22.2%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 1820 
  pacman: 1812 lib: 461 flatpak: 6 snap: 2 Shell: Bash v: 5.0.18 
  running in: konsole inxi: 3.1.08


I am experiencing a weird issue, where left edge on my right screen is displaying 2 pixels from the right edge of my left screen. This is hard to explain using words, so i am attaching picture of this issue. I tried to fix it using KDE’s Display Configuration but nothing worked (I’m also attaching screenshot of the settings i am currently using.)

Xrandr output:

Screen 0: minimum 320 x 200, current 3286 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected primary 1920x1080+1366+0 (normal left inverted right x axis y axis) 510mm x 287mm
   1920x1080     60.00*+
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
   720x400       70.08  
DVI-I-1 connected 1366x768+0+312 (normal left inverted right x axis y axis) 410mm x 230mm
   1366x768      59.79*+
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x800      74.93    59.81  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08


Just want to point out, that this setup works fine under Windows 10.

I would be very grateful for any help. :smiley:

1 Like

Try to drag out your secondary screen away from the primary one and then drag to it again so it would snap edge to edge. At the moment it seems like one screen is overlapping the other. If that doesn’t work, do it again, with the difference that you need to save the configuration when the secondary screen is away and then drag it together then save again.

So i did that, and as expected it didn’t work (I tried that before). But i noticed something interesting. I don’t know if that would help, but: I tried to record it using OBS and inside of OBS the screen looks good (without that weird edge).

Maybe a slight tweak via xrandr will fix it. :man_shrugging:

I noticed this slight overlap a while back when playing fullscreen videos on my mate’s TV using a MiniDP to HDMI lead … in my case, the leftmost couple of pixels of the video overlap the right edge of the laptop display. Dragging the screen away works but dragging it back causes it to “snap” with those two pixels overlapped again.

No apparent issue with the Asus display connected via VGA.

So, moving the right screen by two pixels to the right “fixes” the problem, but at the same time creates another. I made small pictures to better visualize the “new” issue. When the screens are connected (no pixels in between them) then the issue with edge overlapping occurs and the screen setup looks like this:

But when i move the bigger screen 2 pixels to the right then the setup looks like this:

The red rectangle is now a place which i don’t see on my screens but still can move my mouse there. And that’s a issue because eg: I can not easily drag windows to make them fullscreen.

I manage to “solve” this issue. I don’t think that’s a proper solution, but it’s working so it’s a solution never the less. What I did is: I used the --transform option of xrandr command to transform my second screen. I then tweeked it’s parameters and ended with a something that i can work with. This is the command which worked for me:

xrandr --output DisplayPort-0 --off --output HDMI-A-0 --off --output DVI-D-0 --primary --transform 1.0000458,0,0,0,1,0,0,0,1 --mode 1920x1080 --pos 1366x0 --rotate normal --output DVI-I-1 --mode 1366x768 --pos 0x312 --rotate normal

I tweeked the 1.0000458 a lot because when i had it a bit lower, then my screen will be blurry. This number which i ended up with is pretty good, but not perfect and it is still a bit blurry.

Maybe this will help someone who is having similar issue. But i’m still curious what will be the proper solution.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.