Dual monitor setup, one monitor has a grey overlay

Hello y’all!

I am reposting this from the reddit thread.

Let me extend what the title says: I have a Razer Notebook, with an eGPU (AMD Hawaii XT / Grenada XT [Radeon R9 290X/390X]) connected through Tunderbolt (Razer Core) and two monitors.
Installed is Manjaro with Gnome and wayland.

Depending on the resolution + refresh rate one or the other monitor shows a grey overlay over the area that shows the application windows. When the main screen is the one having issues, the top bar with the time/date and logout options is visible. When I move windows around on the screen with the overlay I can see the background and the windows themselves, same when I press the SUPER button to show all open windows, although the grey overlay is there as soon as I go back and try to work.

To have an idea of what I am talking about, here a video:

Here more information about the system:

inxi -SMGxxaz

System:    Host: <redacted> Kernel: 5.7.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=8997e623-856e-4a62-bfd8-08ddea5ab137 rw quiet 
           Desktop: Gnome 3.36.4 wm: gnome-shell dm: GDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Razer product: Blade Stealth v: 2.04 serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Razer model: Razer serial: <filter> UEFI: Razer v: 8.02 date: 02/22/2018 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Razer USA driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
           Device-2: Advanced Micro Devices [AMD/ATI] Hawaii XT / Grenada XT [Radeon R9 290X/390X] vendor: PC Partner Limited 
           driver: amdgpu v: kernel bus ID: 07:00.0 chip ID: 1002:67b0 
           Display: wayland server: X.Org 1.20.8 driver: amdgpu compositor: gnome-shell 
           resolution: 1920x1080~50Hz, 1080x1920~50Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.3 direct render: Yes 

mhwd --pci -li

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

xrandr | awk ’ /connected/ { print $1, $2 }’

xrandr | awk ' /connected/ { print $1, $2 }'
XWAYLAND1 connected
XWAYLAND2 connected

for p in /sys/class/drm//status; do con=${p%/status}; echo -n "${con#/card?-}: "; cat $p; done

DP-1: disconnected
DP-2: disconnected
eDP-1: connected
HDMI-A-1: disconnected
DP-3: connected
DVI-D-1: disconnected
DVI-D-2: disconnected
HDMI-A-2: connected

I tried autorandr like suggested.
I saved the laptop profile, then connected everything and it works well, until I close the lid of the laptop. As soon as I close the lid, the overlay comes back to the display. (I also tried to disable the laptop display from the settings, same behaviour)

Here how that looks like:

I copied the triple monitor configuration and renamed to double.

Original triple

output XWAYLAND2
crtc 2
mode 1080x1920
pos 1920x0
rate 59.87
output XWAYLAND0
crtc 0
gamma 1e-10:1e-10:1e-10
mode 1920x1080
pos 0x452
rate 59.88
output XWAYLAND1
crtc 1
mode 2560x1440
pos 3000x952
rate 59.91

and edited to make it a dual monitor configuration by removing the WAYLAND1 output

output XWAYLAND2
crtc 2
mode 1080x1920
pos 1920x0
rate 59.87
output XWAYLAND0
crtc 0
gamma 1e-10:1e-10:1e-10
mode 1920x1080
pos 0x452
rate 59.88

And now if I try to load the double profile (dual screen) it gives this error:

autorandr --load double

xrandr: cannot find crtc 2
Failed to apply profile 'double' (line 857):
  Command failed: xrandr --fb 3000x1920 --output XWAYLAND0 --crtc 0 --gamma 1e-10:1e-10:1e-10 --mode 1920x1080 --pos 0x452 --rate 59.88 --reflect normal --rotate normal --output XWAYLAND2 --crtc 2 --gamma 1.0:1.0:1.0 --mode 1080x1920 --pos 1920x0 --rate 59.87 --reflect normal --rotate normal (line 857)

xrandr --listproviders

Providers: number : 0

autorandr --fingerprint


Any ideas?

Thank you!

Does xrandr even work with wayland?

As you can see from the video it worked perfectly well to set up all three monitors without having the grey overlay. :man_shrugging:

1 Like

Changing the scale of the lefthand monitor to 125% removed the overlay :man_shrugging: