Dual booting Windows and Manjaro issues

Good day just to start I really try everything before coming here… I got a dual boot laptop with windows and manjaro. I try to run manjaro on a USB keys (yes the all OS) but realise that this is too slow and won’t work… After that I unfortunately lost my boot loader on Linux I can still boot without an issue on Windows but can’t get my manjaro option…
What is even weird for me is if I run a live disk and go to Detect efi boot loader it’s here! I can boot it!!!
So I run manjaro on usb and then try to fix the issue by doing few commands like:
reinstall the grub
etc… Nothing had work so far!
Would anyone has an idea? Thanks you

PATH           PTTYPE PARTTYPE                             FSTYPE PARTTYPENAME
/dev/loop0                                                 squash 
/dev/loop1                                                 squash 
/dev/loop2                                                 squash 
/dev/loop3                                                 squash 
/dev/loop4                                                 squash 
/dev/loop5                                                 squash 
/dev/loop6                                                 squash 
/dev/sda       dos                                         iso966 
/dev/sda1      dos    0x0                                  iso966 Empty
/dev/sda2      dos    0xef                                 vfat   EFI (FAT-12/16/32)
/dev/nvme0n1   gpt                                                
/dev/nvme0n1p1 gpt    de94bba4-06d1-4d40-a16a-bfd50179d6ac ntfs   Windows recovery environment
/dev/nvme0n1p2 gpt    c12a7328-f81f-11d2-ba4b-00a0c93ec93b vfat   EFI System
/dev/nvme0n1p3 gpt    e3c9e316-0b5c-4db8-817d-f92df00215ae        Microsoft reserved
/dev/nvme0n1p4 gpt    ebd0a0a2-b9e5-4433-87c0-68b6b72699c7 ntfs   Microsoft basic data
/dev/nvme0n1p5 gpt    0657fd6d-a4ab-43c4-84e5-0933c84b4f4f swap   Linux swap
/dev/nvme0n1p6 gpt    0fc63daf-8483-4772-8e79-3d69d8477de4 ext4   Linux filesystem

Hi @hsdredgun!
I’m sorry but it’s not really clear what your problem is and what steps you took to address it :thinking:
Here’s how I interpreted your post, correct me if I’m wrong:
your dual-boot set up consisted in Windows, running on your HDD/SSD and Manjaro running on a USB drive.

First question, did you install Manjaro on the USB device or did you create a USB drive with persistent storage?
Or maybe you just booted with the live ISO?

Reading your second post it seems like you installed Manjaro on your nvme ssd so I don’t get the USB part :thinking:

Then, you wrote:

but you don’t explain what actually happened: what are the steps, modifications or problems that led you to loose you bootloader?
Sometimes it’s just as easy as going into the BIOS, find the boot order section and select the Manjaro entry as the first boot option.


I assume you booted in the live ISO and tried to chroot into your existing installation to reinstall GRUB.
I had to reinstall GRUB a couple of times and followed this guide on the forum, it was very helpful!
It teaches you how to manually chroot into your existing installation, so you can recover your bootloader, reinstall GRUB and so on…

1 Like

Good day! Sorry for the confusion here we go I ll clear this one up:
I have windows install on an old laptop and then I install long time ago manjaro on dual booting both are on EFI and one partition is mount to the windows one Never had an issue…
This morning I try to experiment by putting Manjaro OS into a USB and just boot into it and run it for extra privacy this did work but was too slow…
Unfortunately after removing the usb I lost my boot! I could only boot into windows…
I did try this Fantastic post! but this didn’t work…
So the solution was to run a usb image of manjaro go to installation and pretty much just rehook the mount / and hook up the EFI of linux with windows again…
This fixed the issue! And I didn’t lost any data!
Thanks you

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.