Dual Boot - Windows 10 + Manjaro 20.0 - weird behaviour of X570-board

Hi there,
I have a problem where I don’t really understand what happens - my primary objective is to solve the problem in an elegant way, but to better understand the problem would be nice as well. Maybe someone here had the same problem and solved it so I can learn how to deal with it.

I have a server on that Windows 10 is running. I need Windows 10 for specific aspects, but want to run the server mainly with Manjaro - so I decided to install Manjaro alongside Windows 10. As I head in the past a lot of troubles with Windows 10 updates that “destroyed” the dual boot mechanism when I used for both the same EFI partition, I decided to create an own EFI partition for Manjaro. The server has an MSI x570-A Pro with an AMD Ryzen 7 5800x running on it. In MSI x570-A Pro you can choose the boot priorities of the attached drives and for the individual drive between the EFI partitions.

The partitions on that SSD are as follows:

  1. 100 MB - EFI - Fat32 - Windows Bootloader
  2. 16 MB - Microsoft Reserved
  3. 496 GB - NTFS - Windows Partition
  4. 250 MB - EFI - Fat32 - Manjaro Bootloader
  5. 480 GB - EXT4 Manjaro Partition
  6. 515 MB - NTFS (something MS requires)

Now the problem:
When I now choose the Manjaro EFI Partition as the primary boot partition in the UEFI menu (“Bios” where you can make all the settings) the system doesn’t boot - I think the system tries to find and load the EFI partition but than struggles somehow - and falls back into the UEFI menu and the system freezes (that means you have to switch the Server off via Power Off button and on again to be able to get into the UEFI menu and make changes there. The MSI Board in the meanwhile switches automatically back to the Windows EFI partition as the primary boot option.
Now the “weird” behaviour of the board:
When I use F11 which activates the boot menu during the start of the system and manually choose the Manjaro EFI partition it boots into Manjaro - without any problems.

The question is: Does somebody have experienced similar problems with any of the X570 boards and nows how to “repair” the problem?
For me the most realistic options to solve the problem seem to be
a) to use the Windows Bootloader to load Manjaro as the primary option and Windows as the secondary option - but if any possible I would like to avoid going this way.
b) to use the EFI partition of Windows and install there the Manjaro EFI - but according to my experiences in the past that is not a good option because 1. there is the threat that one Windows update destroys the Manjaro EFI boot folder / files and 2. I might have to spend a lot of time to find out whether it works and how it works (e.g. on my HP laptop that does not work).

Does anybody of you had the same problem and solved it via UEFI menu without using the above mentioned from my point of view not very optimal workarounds?

Many thanks for your support.

Kind regards,


Possible that you need to flag the efi partition correctly…
Both partition have to be flagged with boot, esp:

sudo parted -l

Some UEFIs struggle just there…

Hi Megavolt,
Thanks a lot for your quick response.

That was also my first thought when it didn’t work out of the box - so I tried “boot, esp” and also “bios_grub” - what I am wondering about is, that choosing the Manjaro EFI Partition via Boot menu of the MSI board (via F11) it loads Manjaro, with both of the mentioned settings. I thought that UEFI should require always boot, esp for the EFI partition but somehow with F11 it worked also with bios_grup.

But considering, that the board finds and starts the Manjaro EFI via F11 manual selection in the boot menu I think the problem must be some specifics of the board itself and not of Manjaro.

I think the problem can be one of the following aspects:
a) The structure of the EFI directory (e.g. name of the directory / the EFI file)
b) I used a 250 MB efi partition for Manjaro whereas for Windows the efi partition is 100 MB - might be that somehow that brings problems with it
c) The Manjaro EFI partition is the 4. partition - maybe it matters…

I will try to solve the problem and come back with a solution - let me know if you have any other idea…

Many thanks.

Kind regards,

So - I have now tried some aspects and found out some really strange things, but also found the solution - the problem is, that the MSI board expects to find bootx64.efi, instead it finds in /boot/efi/EFI/Manjaro grubx64.efi. For me it is a bug, it is not a feature as via F11 you can choose Manjaro to be loaded, but not with setting the boot order in the Bios.

I copied grubx64.efi to bootx64.efi - so now I can set the boot priorisation via efibootmgr.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.