Dual Boot when system is BIOS/MBR

I am unable to complete my dual boot installation with this guide. My system came with Win 10 preinstalled (two primary partitions) and I want to try dual boot for the first time.
However I cannot get past “Manjaro Installation Step 7” because I am not allowed to create more than four primary partitions in total.

In this guide unmentioned is whether to choose Partition Type “Primary” or “Extended” for each partition EFI, SWAP, ROOT, HOME so I’ve chosen the default “Primary” in each step and came up with this error.

It now always pops up when clicking “Create” and I don’t want to try changing any partition to “Extended” on my own (if that even works). How to solve this issue?

You actually answered the question yourself.

A disk using MBR allows four (4) primary partitions - GPT allows for 128.

The guide is not applicable to a BIOS/MBR system.


In order to comply to the guide, you first have to change your partition table from MBR to GPT. You can do that with Gparted or even with the partitioning tool from the installer.

But it will erase all your disk. Make sure to backup correctly before.

1 Like

@p-value, as far as I can see you have Windoze using two partitions and you are probably running in BIOS mode with a msdos parted disk. Make sure this is correct!! Make sure as well that fast boot are switched off in your firmware and Fast startup is completely disabled in Windoze.

In this case you simply need to boot the live ISO in BIOS (legacy) mode from your firmware and then create in Calamares in manual partition mode 2 partitions, one for / and one swap (if you want). Make sure to select MBR as location for the boot loader, then you should be fine.

There is absolutely no need to change anything to UEFI mode or repartition to gpt, BIOS mode and msdos parted disks run fine with dual boot.

1 Like

Thank you for all the suggestions.

I wasn’t very careful when reading the start of the guide and simply assumed Win 10 on a new system means you can follow the UEFI route. Indeed “sudo fdisk -l” in the live environment still shows “dos” in the output. At least I have now learned a major difference between MBR and GPT …

Meanwhile I booted in the live environment and have chosen the automatic installation for the unallocated disk space as seen in the picture (shrinked via Win10 beforehand) and dual-boot works out-of-the-box. Of course now swap isn’t set up but that doesn’t concern me right now (had a massive RAM upgrade and won’t need all of it before summer).

1 Like

Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Check out the wiki on swap, a dedicated partirion is no longer required in all cases.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.