Dual-boot on Dell XPS 9500 [Solved]

Hi,
I had Manjaro installed in dual-boot on my old Lenovo laptop, which went quite smoothly so I decided to install it as well on my new Dell XPS 9500.

I created LiveUSB with Rufus and manjaro-kde-20.2-201207-linux59 image, then followed this installation guide posted on this forum: /t/root-tip-dual-boot-manjaro-and-windows/1164. I’ve created a new EFI partition following guide’s suggestion and finished the installation without any problems.
After first reboot I was shown Windows so I checked my UEFI settings and saw Manjaro on the first place.
I tried to boot Manjaro using one-time boot configuration (F12) but I was shown a black screen with 3 options (“Press F1 to retry”, “Press F2 to go back to configuration”)

I’ve also tried to boot again from LiveUSB to use a list of bootloaders provided by the LiveUSB, which gives me 6 entries:

  1. (hd1,gpt5)/efi/Manjaro/grubx64.efi
  2. (hd1,gpt5)/efi/boot/bootx64.efi
  3. (hd1,gpt1)/efi/Boot/bootx64.efi
  4. (hd1,gpt1)/efi/Microsoft/Boot/bootmgr.efi
  5. (hd1,gpt1)/efi/Microsoft/Boot/memtest.efi
  6. (hd1,gpt1)/efi/Microsoft/Boot/bootmgfw.efi

However, when I try to run (hd1,gpt5)/efi/Manjaro/grubx64.efi then I’m getting a black screen with an error saying:
error: not a valid root device.

What can be a reason for the troubles of booting into Manjaro?
Is there a way for me to debug it and get more information of what causes it?

Thanks!

Solved!
I used gparted to check flags set on partitions and learnt that my gpt5 partition had legacy_boot flag set instead of boot. I modified flags using the application and now everything works fine :slight_smile:

I have a 9550 and sometimes I have to poke around int the settings similar to this image.
You could try to view/add your data there.

Edit: Linked the wrong image at first…

Hi Trixon,

I’ve already played with UEFI settings based on various information online:

  • Changed Dell’s default RAID to AHCI
  • Disabled Secure Boot
  • Moved Manjaro boot to first place
  • Changed Pre-boot/Fastboot to Through

None of the changes helped

You could also try to add a boot option, pointing to the correct file.
Not saying that you have the wrong one now though.

I managed to make a progress but I’m not sure how to make it persistent and why the other EFI partition is not considered a root device.

With Manjaro LiveUSB I’m able to list EFI bootloaders:

  1. (hd1,gpt5)/efi/Manjaro/grubx64.efi
    
  2. (hd1,gpt5)/efi/boot/bootx64.efi
    
  3. (hd1,gpt1)/efi/Boot/bootx64.efi
    
  4. (hd1,gpt1)/efi/Microsoft/Boot/bootmgr.efi
    
  5. (hd1,gpt1)/efi/Microsoft/Boot/memtest.efi
    
  6. (hd1,gpt1)/efi/Microsoft/Boot/bootmgfw.efi
    

I used “E: Edit Boot Option” on the first entry which showed me that the entry is defined with chainloader=(hd1,gpt5)/efi/Manjaro/grubx64.efi and root=(hd1,gpt5). When I edited the root param to be root=(hd1,gpt1) then I’m able to launch my Manjaro. This option is not persistent though - how can I change it so I don’t have to boot from my LiveUSB every time to get into Manjaro?

This post was flagged by the community and is temporarily hidden.