Dual boot not working

Hi all

I’ve just had a look at the previous posts about this, but can’t find anything similar to my issue.

I’ve installed Manjaro as a potential alternative to Windows, however my wife does need access to Windows. As such, I took a completely different M.2 drive to use for Manjaro, separate from my Windows installation M.2 to try and remove the error I’m now receiving (Best laid plans and all that!).

I ‘F2’ into BIOS and select the windows M.2 as primary boot drive; but I now get the “Insert a bootable drive and press any key to continue” every time.

Is there something I’m missing? Please note, I’ve not touched Linux/Terminal in over a decade; so please treat me as an idiot.

PC hardware as follows:

i7 10700KF
32Gb RAM
RTX 2080
Samsung 970 (Manjaro boot disk)
Seagate Firecuda ZP500GM30002 (Windows boot disk)
Samsung 860 (Storage)

In general that has nothing to do with Manjaro, but with Windows… If it is separated on 2 different drives then Manjaro can’t be the cause of this. However, please provide more information:

  1. Open a terminal
  2. type this:
sudo parted -l
lsblk -fs
efibootmgr -v

Please post each output as code like this:


1 Like

sudo parted -l

Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  2000GB  2000GB  primary  ntfs

Model: Seagate FireCuda 520 SSD ZP500GM30002 (nvme)
Disk /dev/nvme0n1: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  500GB  500GB  primary  ntfs

Model: Samsung SSD 970 EVO Plus 500GB (nvme)
Disk /dev/nvme1n1: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  457GB  457GB   primary  ext4
 2      457GB   498GB  40.8GB  primary  fat32           lba
 3      498GB   500GB  2593MB  primary  linux-swap(v1)

lsblk -fs

sda1 ntfs         BETSY 01D6D0A9C9B12AD0                        1.5T    19% /run/media/_gckr/BETSY
│    ntfs               42923AEF923AE757                      111.1G    76% /run/media/_gckr/42923AEF923AE757
│    ext4   1.0         a21432d7-e401-4ffe-b58a-352bc071ea30  388.1G     2% /
│    vfat   FAT32 NO_LABEL
│                       C73C-175D                                38G     0% /boot/efi
│    swap   1           60c2900e-96a9-46c6-bf27-4567fa789d23                [SWAP]

efibootmgr -v

BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0005,0001,0000
Boot0000* Manjaro	HD(2,MBR,0x675413b0,0x352a1000,0x4c0f800)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0001* Hard Drive	BBS(HD,,0x0)..GO..NO........c.S.e.a.g.a.t.e. .F.i.r.e.C.u.d.a. .5.2.0. .S.S.D. .Z.P.5.0.0.G.M.$..L.2......&..Gd-.;.A..MQ..L.7.Q.F.0.0.B.7.2........BO..NO........q.S.a.m.s.u.n.g. .S.S.D. .9.7.0. .E.V.O. .P.l.u.s. .5.0.0.G.B....................A...........................%8S.AU".....4..Gd-.;.A..MQ..L.S.4.E.V.N.J.0.N. .S.S.D. .8.6.0. .E.V.O. .2.T.B....................A...........................>..Gd-.;.A..MQ..L.3.S.V.Y.B.N.N. .D. . . . ........BO
Boot0005* UEFI OS	HD(2,MBR,0x675413b0,0x352a1000,0x4c0f800)/File(\EFI\BOOT\BOOTX64.EFI)..BO
1 Like

Ok i have an Idea what could be done wrong.

You have an UEFI and use the CSM (legacy BIOS), wouldn’t it be better to use pure UEFI?

  1. If Manjaro boots, then I think you (over)wrote the MBR for Manjaro on the Disk for Windows.
  2. You need to write MBR for Windows again with bcdedit I guess?
  3. Write the MBR on the correct Disk:
sudo grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/nvme1n1

Installing for i386-pc platform.
Installation finished. No error reported.

Is that the job done?

Yes, Manjaro should now use the MBR of its own drive. Maybe also sudo update-grub to update the config.

The Windows part have to be done with Windows Setup Disk on the CMD.

@Aceformat, I guess your Windows is installed in BIOS mode and somehow you tried to install Manjaro in UEFI mode. Could that be the case? In this situtaion just reinstall Manjaro in BIOS mode by selection the non-“UEFI” entry when booting the installation stick. Place the boot loader in the MBR and you should be fine.

Keep in mind:

BIOS + msdos parted disk (with MBR)


UEFI + gpt parted disk

In dual boot situations never mix the two cases for the OS. Otherwise you cannot use the grub boot menu to boot all your OS.

Details you find in the wiki and Manjaro tutorials.

Yeah that was also my thought, but this entry must be of the past:

since this drive:

has 40GB. I would rather say it is a “exchange disk” between Windows and Manjaro than a EFI Partition. It would be just a little bit oversized for that… only a bit :laughing:

Yes, just a little bit. :grinning_face_with_smiling_eyes:

Nevertheless, the disks are msdos parted and efibootmgr provides a typical UEFI boot output, this does not go well together I think…

Yup, I done screwed up, windows boot USB can’t fix it, I did use more than the actual required exchange disk from the ‘how to’ on installing Manjaro.

I’ve no idea how to get to Grub or set it running. Is this because i used a separate drive to install Manjaro?

No wonder Windows can not do it automatically, you have to use the CMD.

What is the current state? Did Grub work before?

No, I guess not, normally it should work. But most Manjaro User use UEFI without Problems. Problems occur with old legacy BIOS Setups as I see on the forum posts. I, myself, have all systems which are running Manjaro on UEFI only and disabled legacy BIOS completely.

But if Manjaro is running UEFI mode and Windows in BIOS mode, then Grub will not find Windows and add it to the menu. Just keep that in mind.