Dual boot Manjaro and Windows 10 no longer working

I have no clue on what went wrong. A friend of mine I set his computer up years ago. I have it dual booted with manjaro and windows 10 installed. Right now I can get manjaro to try and boot but it will hand at a certain spot. If I try to boot windows 10 it says no OS detected.

I made a live cd of ubuntu and ran the boot repair tool.

Here’s the output: grub needs fixing - Pastebin.com

The sdc drive is my usb ubuntu live boot.

I tried using the boot repair tool to fix the boot issues but it goes to an error saying to add a repository for manjaro grub 2.

I then used a live usb image for manjaro and followed tutorials on chrooting and mounting my manjaro drive and ran the install grub command which ran fine but the moment I do update-grub I get a list of socket errors and it end in failure.
I would like to know what I can do to try and restore the system to be bootable again.

Thanks.

when did it started happen, after the update?
and also check this in the output of yours:
The default repair of the Boot-Repair utility would purge (in order to fix packages) and reinstall the grub2 of sda1 into the MBR of sda.
and:
The boot of your PC is in UEFI mode. You may want to retry after changing it to BIOS-compatibility/CSM/Legacy mode.
but, this is really interesting:
Manjaro Linux (Kernel: 3.10.37-1-MANJARO x64) - if you really running this old kernel, just do a clean install of manjaro - donwload latest iso, flash it using ventoy, and install it …

why not the live cd of manjaro and repair?

which tool?

where is the output?

It is indeed possible that this installation has not been updated or maintained since the time it was first installed - which was some time in the year 2014.
Fixing that with contemporary tools could prove challenging to the point were it is not worth trying.

What could have “happened” is that you somehow - in the BIOS/Firmware settings - changed the boot mode from compatibility to UEFI
and that neither system can now boot because of that.
… check this …

the last line of your pasted report says:

The boot of your PC is in UEFI mode. You may want to retry after changing it to BIOS-compatibility/CSM/Legacy mode.

Even if successful, this doesn’t change the fact that the Manjaro installation is … very old and probably not worth the effort of trying to update.
But this is just speculation based on the kernel version - it could be up to date otherwise.

The computer has dual boot one is manjaro and the other is windows 10 but it’s called windows7_part because it was upgraded from windows 7 to windows 10 2 or 3 years ago.

The errors I got when using manjaro live usb was when I did a update-grub command it states the LVM.sockets couldn’t be found and had errors. I googled this and most claim this issue is due to me being chrooted and the var folder needs to be mounted as root.

I used ubuntu live usb because it has repair boot and tried using it but filed asking for manjaro respoitory for grub2. I also generated the report with it and that is live usb is gpt partition and is what I booted up with which is why you’re seeing those errors. The computer supports UEFI but the drives and the OS installed when it was first installed the drives were formated with the old system. I kept t that way because I want to avoid issues for my friend.

This started 4 days ago but it could have been longer than that. 4 days ago an anti-virus ran and it picked up some files to delete and my friend approved it. A month before this I recalled him asking if he should deleted a file this was on the windows 10 machine. I said you can but don’t delete it but leave it in recycle bin. I assumed that if it was critical file I can always boot in using a live usb and move the file back. However, my friend isn’t tech savy so I said for him to not do anything to system files. That next day he told me he deleted it and emptied the recycle bin. However, he puts his computer to sleep most of the time. 4 days ago the anti-virus software he used asked him to restart his machine and he clicked ok but before this there were windows updates that completed. So, I don’t know exactly the cause but after reboot. He would go to grub and select windows 10 to boot and after selecting it from grub it would show texts saying no OS detected on this device. press alt ctrl del to reboot. The manjaro OS tries to boot it you can see the commands runs and he hasn’t used manjaro.

My question is can I install the latest manjaro onto that partition where the old one is? My friend doesn’t have anything critical on that. He just has a lot of data he cannot afford losing on the windows 10 machine which are legal papers and tax forms. I told him countless of times to have a external usb drive to back up important data and he claims he will do it eventually but never does.

My question is should I reinstall manjaro and if I do would this damage windows 10? It won’t wipe windows 10 clean? from my understanding the boot repair and other things detect windows 10.
The bios of the machines doesn’t let you choose to use legacy mode or not. I will double check this since I already looked thru it.

Thanks for the replies.

This is true… I installed it for my friend and not sure the year but sounds to be right back in 2014. I wanted him to try linux. He never really touched it. I think I showed him a couple of times. I gave him the user password etc and I think he lost it. I can do a new install but just want to make sure it doesn’t damage the windows 10 partition. I think by doing this I can get grub to run properly. I couldn’t run the command update-grub because it issues errors about the lvm sockets there’s directories missing and the lvm.socket is missing. but I did this in chroot. I ran this commands in manjaro live usb.

Let me know if I should do a clean install. I do have a live manjaro usb but I avoid this because I am not sure if this will in any way damage the windows 10 install. I ran ubntu live cd to copy over the windows 10 machine files which is said to be around 800gb but my copy shows a total of 70gb because it skipped appdata that seems to be encrypted folders for programs.

let me know if it will be safe for me to install the latest manjaro OS? I think this would be the best solution that way I will be working with current tools that should work.

I have an ISO file but I am using rufus but rufus claims this needs to be using DD so it installs it as a DD onto my external usb hard drive. I am thinking to do this. I think that way I can use grub and the friend never really used it. I installed linux for him to try it out and also if windows has issues I have a way without using a live usb drive to get access to the windows files.

Let me know if it’s ok for me to write a new manjaro OS and that it won’t damage the windows 10 installation.

A better option would ventoy: Download . Ventoy

Just install it on the flash drive and copy the iso file into the ventoy partition. Then boot it.

1 Like

ok I will but with the new manjaro I will be good that it shouldn’t damage the windows 10 partition?
I won’t have to use the GPT and if I have to use it it wouldn’t make a difference if the windows 10 partition isn’t gpt…? correct?

Overwriting the USB Flash Drive with ventoy for booting Manjaro Installation Disk? No, it will not damage Windows.

No, since it seems it is pure BIOS, you have to remove the Linux Partition, create a new one and install into that. The MBR will written again. But note: On BIOS only one Bootloader can be targeted. GRUB or bootrec. But Grub can boot Windows aswell.

Switching from MSDOS to GPT requires normally a full reset of the drive (delete everything). MSDOS is the preferred Partition Table for pure BIOS. UEFI → GPT. BIOS + GPT needs normally an additional partition for grub.

no, the windows installation wont be damaged, unless its already damaged according to your post above…
download/torrent latest manjaro kde from here - good for windows users
download ventoy and install it onto a usb, then copy manjaro iso kde onto the ventoy usb, boot from the live usb, backup the documents you mentioned, and install manjaro - it should fix the windows not loading, unless windows is damaged - if its, youll have to run windows recovery …

I reinstalled manjaro and followed your instruction. I replaced the manjaro partition and the first time around it installed the latest manjaro but when it got to installing the bootloader it gave an error message that there’s no EPI. I had to power off the computer and power on. I then did another install and it installed the bootloader with no issues. I was now able to boot into windows 10. Everything now works.