Dual Boot Linux in UEFI

I decided to eliminate W8 and reinstall Manjaro and xubuntu (both xfce versions) in dual boot in a UEFI computer. I can solve that with MBR/GRUB but I am discovering at the same time the world of UEFI but still do not understand. Most of the help I can find is about dual booting with W ans the question is a bit different.

I did install Manjaro with GPT and /boot/efi partition but possibly did something wrong with the instllation of xubuntu; I suppose that I used and marked /boot/efi as requested WITHOUT formatting - as I would for swap - but the computer did reboot with Xubuntu directly (no GRUB-like option).

I did reinstall Manjaro Grub with sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck and sudo update-grub from Manjaro system and came back to my usual GRUB with two options.
After that, I rechecked with gdisk /dev/sda1 and have the surprise to see MBR Only and GPT not present… Not exactly what I did expect…

I did see the option of rEFInd but I fell that my traditional Manjaro GRUB is much nicer. Can you explain and help?

Thank you!

Please search the Forum, this theme is solved many times :innocent:

That is NOT UEFI, GPT is.
The partitiontable on the DISK also needs to be GPT.
Remove all things MBR.

You probably have to move stuff you want to keep to another disk. Format the drive using GPT, recreate partitions, move data back and THEN reinstall grub using efi method.

If you post output of lsblk -o name,pttype we can confirm if this is the situation.

You shouldn’t mix bios and uefi, mbr and gpt. Otherwise you will need to change the mode in the bios every time before booting the other system.
Besides, make sure secure boot is off. Ubuntu is compatible, manjaro is not.

Well, I did not really find the dual boot of linux WTIHOUT windows and I am a newbee of GPT and efi…

That is exactly my problem, I did try to make all clean and to eliminate MBR but it did come back for some error in my procedure? I am making a complete wiping of the disk and reinstall everything.

I have requested information, unless you provide, nobody will know exactly.

This has been done when installing manjaro with a new GPT table, /boot/efi partition and new partitioning for the systems.

sda gpt
├─sda1 gpt
├─sda2 gpt
├─sda3 gpt
├─sda4 gpt
│ └─luks-36700c03-b41d-4dfc-a466-ae65b6a66586
└─sda5 gpt

Reviewing a bit, the output of df -h is

Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
dev 3,6G 0 3,6G 0% /dev
run 3,6G 1,5M 3,6G 1% /run
efivarfs 128K 109K 15K 88% /sys/firmware/efi/efivars
/dev/dm-0 98G 8,4G 85G 10% /
tmpfs 3,6G 0 3,6G 0% /dev/shm
tmpfs 3,6G 8,0K 3,6G 1% /tmp
/dev/sda1 511M 6,4M 505M 2% /boot/efi
tmpfs 737M 100K 737M 1% /run/user/1000

And gdisk /dev/sda gives (I did first mention that GPT was apparently NOT present but this is when I apply gdisk on the parttion /dev/sda1 instead of the disk itself)

GPT fdisk (gdisk) version
Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.

Sorry for this long post and possible lack of follow up also at my side in these days!
Thanks a lot for your suggestions, I consider reinstall this all (if mistaken) but do not know where I did make a mistake!
Have a happy Xmas!

1 Like

The second I see that I have to say sorry, can’t help so…
Sorry, can’t help.
You might want to edit the topic to let ppl know encryption is involved.

Luks partition is not really problematic, this is just like another system partition that I have to open wit a password at the very beginning; afterwards it is a normal partition. Well I do not think that it is the reason for my problem of mixed MBR/GPT

Then idk what is going on here, this should be the partition you want to use as root in df

Is identified as your boot partition and mounted in efi mode.

What exactly is the problem you are having?

I am not sure. My system is working as I wanted and this is nice.
Nevertheless I have the impression that something got mixed up with MBR present in gdisk (and I also do not even see GPT in sda1 partition!). As I do not fully understand GPT and EFI, I am not sure of the result.

I would like to make sure that my system is really clean before I reinstall the applications, config and files.

Sorry if it is not clear but this what I tried to explain in the first post when describing the installation process of Manjaro followed by Xubuntu.

In other words, possibly more clear:

  • I did install Manjaro in UEFI mode (GPT table and /boot/efi) and ended up with no grub or equivalent when launching
  • I managed to install Ubuntu also in a second partition but still with no Grub or equivalent…
  • I may have messed up with sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck and sudo update-grub

Yeah, you probably have to read that tutorial on how to ask questions. You are looking for the grub menu.

Edit the grub config with your favorite editor, I use nano:

sudo nano /etc/default/grub

And make sure following is included:


You can obv change the time frame.

Then run sudo update-grub

I should warn you though. If you are using the same partition for 2 linux distributions, both using grub, it could complicate things when running updates unless you make sure one of the systems does NOT ever update grub but you rather do that on ONE of the systems and then let os-prober find the other installation.

Another solution would be to have 2 fat32 partitions, one for each linux installation and then just prioritize whatever system you want in your bios. Both distributions would be startable from grub anyway since os-prober will detect the other.
:point_up_2: :point_up_2: :point_up_2:
This is what I would do.

You may also have a look at:


At the end of the holidays, I would like to conclude on my solution for double booting with a (partly) encrypted system. Very simple in fact, and logical.

If you want to install various system in your computer with one encrypted system partition, you have to make sure to CONCLUDE with the encrypted system as grub-install will identify the other systems and the encrypted one at the same time. All the other will be unable to identify the encrypted system, as it is encrypted!!

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.