Dropped into emergency shell after manjaro i3 installation

Hello everyone,
I am relatively new to Linux and had perviously manjaro kde installed. Now I wanted to try out the community edition “Manjaro i3”. During installation i replaced the partition previously used for the kde desktop and installed i3 on the 50 GB Partition. I am using Linux as dual boot next to windows.

I am able to complete the installation without any problems. After the reboot though I am always getting one of these messages:

No irq handler for vector
ERROR: device 'UUID=234324...' not found. Skipping fsck.
mount: /new_root: can't find UUID=234324...'
You are now beeing dropped into an emergency shell.
sh: can't access tty: job control turned off

Sadly even after multiple reinstallations I can’t get it to work. I have no clue what this problem could be as i had no problems installing manjaro kde. Would be glad if someone could help me.


The UUID of your root filesystem is incorrect. If you reformatted the partition formerly used by the Manjaro KDE installation, then your UUID will have changed.

Boot up from the installer medium ─ CD/DVD or USB stick ─ in live mode. Open up a terminal window and issue the following commands… :arrow_down:

sudo su -
manjaro-chroot -a

If offered a choice, select the partition with Manjaro. Then run the following command… :arrow_down:


… and copy over the UUID of the Manjaro partition. Next, issue the following command… :arrow_down:

nano /etc/fstab

Look for the line that mounts your root partition and verify that the UUID is the same as what you’ve just copied. Change it into the latter if necessary.

Save the file with Ctrl+O followed by Return/Enter and exit the editor with Ctrl+X. Now issue the following command… :arrow_down:

nano /boot/grub/grub.cfg

Verify that the UUID listed in there for the Manjaro root filesystem also matches the one you just copied, and if not, change it ─ note: there may be multiple instances of the Manjaro root UUID in the file, so make sure they are all correct. If you had to change them, save the file and exit the editor as you did earlier in the case with /etc/fstab.

Now issue the following commands ─ I’m not sure whether the first one is needed, but it won’t hurt… :arrow_down:

mkinitcpio -P

It should now be safe to reboot, and if all went well, you will be booting with success. :crossed_fingers:

Hey, thanks for your help. Unfortunatly I still get the same error.
lsblk did not return the uuid but blkid did.

/dev/nvme0n1p5 UUID="uuid..." BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="root" PARTUUID="partuuid..."

UUID matches with /etc/fstab and matches with all uuids in /boot/grub/grub.cfg

What I don’t get is why the Error message is mount: /new_root: can't find UUID. Why is it not mount: /: can't find UUID?
Do I have to adjust /etc/fstab to UUID=1234134... /new_root ext4 default,noatime 0 1 instead of just /?

Just /.