Dropbox hanging on PyQt5.QtDBus.so

Hi, I am not sure when this began happening but after a recent update I believe, dropbox is no longer syncing. It just gives the message “starting” and hangs there if I do dropbox-cli status. If I start from the command line, it loads fg extensions until it reaches the line

dropbox: load fq extension '/opt/dropbox/PyQt5.QtDBus.so'

It just hangs there at that point. Thanks in advance for any help. I will provide inxi output in a reply.

I tried a number of different fixes, including deleting .dropbox and .drobbox-dist as well as following the uninstall instructions at the dropbox site.

It also fails when installed as a flatpak through bauh.

So … the AUR package ‘dropbox’ ?

Please familiarize yourself with how to use the AUR.

I am relatively confident this is simply a case of needing to rebuild your foreign packages with/against your updated system libraries.

For example … for this single particular case (you may use yay, paru, pamac, or any aur helper):

yay -Sua dropbox --rebuild

Or in the case of the recent python upgrade to 3.11

yay -Sua $(pacman -Qoq /usr/lib/python3.10) --rebuild

Or to batch rebuild all of your foreign (AUR) packages because you never have:

yay -Sua $(pacman -Qmq) --rebuild

as promised:

rich[~]$ inxi -Fza
  Kernel: 6.2.0-2-rt3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.2-rt-x86_64
    root=UUID=1d6177fd-3668-4ec7-8be1-cbefdca75a13 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Cinnamon v: 5.6.8 tk: GTK v: 3.24.37 vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 7070 v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Dell model: 0YNVJG v: A02 serial: <superuser required> UEFI: Dell
    v: 1.2.1 date: 11/14/2019
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K360
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: Intel Core i7-9700 bits: 64 type: MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xF4
  Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB L3: 12 MiB
    desc: 1x12 MiB
  Speed (MHz): avg: 800 min/max: 800/4700 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 48000
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: Dell
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: DP-2,HDMI-A-1 empty: DP-1, DP-3, HDMI-A-2, HDMI-A-3
    bus-ID: 00:02.0 chip-ID: 8086:3e98 class-ID: 0300
  Device-2: Logitech HD Webcam C510 driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-10:5
    chip-ID: 046d:081d class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: modesetting
    alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3000x1920 s-dpi: 96 s-size: 794x508mm (31.26x20.00")
    s-diag: 943mm (37.11")
  Monitor-1: DP-2 pos: primary,top-right model: Dell U2417H serial: <filter>
    built: 2016 res: 1080x1920 dpi: 93 gamma: 1.2 size: 296x527mm (11.65x20.75")
    diag: 604mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-1 pos: bottom-l model: Asus VE247
    serial: <filter> built: 2012 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
    size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: Logitech HD Webcam C510 driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-10:5
    chip-ID: 046d:081d class-ID: 0e02 serial: <filter>
  API: ALSA v: k6.2.0-2-rt3-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off with: 1: a2jmidid status: off 2: nsmd
    status: off tools: agordejo, cadence, jack_control, jack_mixer, qjackctl
  Server-3: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bb class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1
    bus-ID: 1-12.3:11 chip-ID: 0a12:0001 class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 2.1
    lmp-v: 4.0 sub-v: 22bb hci-v: 4.0 rev: 22bb
  Info: acl-mtu: 310:10 sco-mtu: 64:8 link-policy: rswitch hold sniff park
    link-mode: peripheral accept service-classes: rendering, capturing, object
    transfer, audio, telephony
  Local Storage: total: 28.43 TiB used: 13.77 TiB (48.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC601 NVMe 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 80002111 temp: 43.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 3B6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: Expansion Desk
    size: 7.28 TiB block-size: physical: 4096 B logical: 512 B type: USB
    rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: 9401
  ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD101EMAZ-11G7DA0 size: 9.1 TiB block-size: physical: 4096 B
    logical: 512 B type: USB rev: 3.1 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 3012 scheme: GPT
  ID-5: /dev/sdd maj-min: 8:48 vendor: Western Digital
    model: WD120EDAZ-11F3RA0 size: 10.91 TiB block-size: physical: 4096 B
    logical: 512 B type: USB rev: 3.1 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 1030 scheme: GPT
  ID-1: / raw-size: 133.79 GiB size: 130.63 GiB (97.64%)
    used: 67.35 GiB (51.6%) fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 931.51 GiB size: 915.81 GiB (98.31%)
    used: 709.75 GiB (77.5%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
  System Temperatures: cpu: 45.0 C pch: 55.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 413 Uptime: 4h 54m wakeups: 8 Memory: available: 54.71 GiB
  used: 10.84 GiB (19.8%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 alt: 10 clang: 15.0.7 Packages: 3008
  pm: pacman pkgs: 2988 libs: 584 tools: pamac,yay pm: flatpak pkgs: 10
  pm: snap pkgs: 10 Shell: Bash v: 5.1.16 running-in: gnome-terminal
  inxi: 3.3.27

I have run yay -Syu dropbox dropbox-cli nemo-dropbox and chosen the clean build option but I am trying with your options right now. thanks for the quick answer.

I then ran yay $(pacman -Qoq /usr/lib/python3.10) --rebuild

this ran with no screen output, which in yay often means nothing happened. Was there supposed to be output showing what was being done?

Since neither of those had an effect, I am holding off for the moment on cleanbuilding everything else because everything else is still working. I am fairly familiar with the AUR. I didn’t mention it explicitly because I posted in the AUR section of the board.

somehow I dropped the action flags. :sweat_smile:
See again, ex;

yay -Sua $(pacman -Qmq) --rebuild

lol, I’ll have to check back in a while if it is rebuilding everything. good excuse to clean out some crufty AUR packages.

I have cleaned out cruft and rebuilt my whole installed AUR.

  • I ran a modification of the command you gave overnight. I modified my sudo time out from five minutes to 3600 minutes and ran the command as follows to be mostly but not quite unattended:
yay -Sua $(pacman -Qmq) --rebuild --noprovides --answerdiff None --answerclean All --mflags --noconfirm

it went overnight and then some.

  • I manually fixed or removed anything that kicked up errors.

  • Just for good luck I rebooted at that point. Everything up to date in main repos and foreign.

  • All the programs that worked are now rebuilt but dropbox still hangs at the line:

dropbox: load fq extension '/opt/dropbox/PyQt5.QtDBus.so'

I then tried

yay -Sua $(pacman -Qoq /usr/lib/python3.10) --rebuild

This time it kicked up a list of 359 items to rebuild, the vast majority of them in the main repos and about a dozen in the AUR. Dropbox was not one of the programs in this list. I did not and probably will not execute this command as it looks like a system-borking thing to do, and the system works except for Dropbox. Going through that list, I did find the following which seems to be related to the fg extension Dropbox hangs on:

285/359  extra/python-pyqt5    -> 5.15.9-1



Python has not upgraded to 3.11 yet, which @ cscs thought was the case, which is probably why the command output 359 programs:

rich[~]$ python --version
Python 3.10.10

Is Dropbox looking for 3.11 maybe?

  • Finally, I downgraded Dropbox to the March 30 snapshot in the AUR GitHub to restore a version that I know was working at that time. Same error with it hanging on “starting” and the last thing to happen was loading fg extension PyQt5.QtDBus.so.

Pretty stumped by this, the only thing that seems sure is that it is something to do with python qt5 and dbus rather than Dropbox itself. I do need to get Dropbox running again, so any further insights would be welcome.

How many foreign packages do you have??

Are you up to date?
All the above was assuming you were and on a branch other than stable.
If you are on stable then yes … python is still 3.10.
(seeing your profile … it appears you are on Stable branch)
Make sure to run first:

sudo pacman -Syu

Or … in the case of needing to sort mirrors:

sudo pacman-mirrors -f8 && sudo pacman -Syyu

But … to get back to the branch thing.
This is likely the cause of your error in the first place … the AUR is targeted at Arch … manjaro stable, especially at times like right now … is rather behind. So incompatibility with some of the AUR is expected. When the next major update (and python 3.11) come then you should be able to interact with it more normally for a time. Of course this and you would be better served by using another branch if you intend to use the aur … and apparently so profusely.

that would be the hope.

I have had problems with the unstable branch that led to reinstalls. I have been using Manjaro since pretty much the day it came out, and use the aur in such a way that if something fails there I can generally fix it delete it or wait. Dropbox is an exception to that in that it is pretty much a requirement for my work, so having it fail is a must fix. I can get by for a little bit by backing up locally until I get it fixed, since I am done with going into work for the summer and fall (yay, sabbatical!) and can get things to Dropbox manually if I need to. I have this mentioned at the AUR too to see if anyone else is having the problem, but I am at risk there of getting my head bit off if they figure out I’m on Manjaro! I guess I’ll wait to see what happens next release. Thanks for the help.

There’s an option for that. I also use batch install.

              Loop sudo calls in the background to prevent sudo from timing out during long builds.

              When building and installing AUR packages instead of installing each package after building, queue each package for install. Then once either all
              packages are built or a package in the build queue is needed as a dependency to build another package, install all the packages in the install queue.
1 Like

found the problem. Fresh install. Dropbox choked on some unwritable files. I had to run `chattr -R -i ~/Dropbox’ and found them. Once I removed them from Dropbox, all was good. More here on the details.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.