Drm atomic helper flip_done timed out

Hi newbie here,

my boot times are about 10+ min and it seems to me that quite some time is spend on an error

> dmesg
[  561.078691] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:91:pipe A] flip_done timed out
[  571.105330] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:91:pipe A] flip_done timed out
[  581.132012] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:91:pipe A] flip_done timed out
[  591.158670] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CONNECTOR:215:eDP-1] flip_done timed out
[  601.185336] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:31:plane 1A] flip_done timed out
[  611.212016] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:91:pipe A] flip_done timed out
[  621.238660] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:91:pipe A] flip_done timed out
[  631.265335] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CONNECTOR:215:eDP-1] flip_done timed out
[  641.291993] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:91:pipe A] flip_done timed out

i searched the error and tried adding “video=SVIDEO-1:d” to the kernel parameters (updated with update-grup ), but that did not help.

here is some info

> inxi -Fza
System:    Kernel: 5.7.17-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64
           root=UUID=bb7308de-27e8-4b2e-945a-994b9c105dde rw video=SVIDEO-1:d apparmor=1
           security=apparmor udev.log_priority=3
           Desktop: i3 4.18.2 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:   Type: Laptop System: Razer product: Blade Stealth 13 (Early 2020) - RZ09-0310 v: 2.04
           serial: <filter> Chassis: type: 10 serial: <filter>
           Mobo: Razer model: LY325 serial: <filter> UEFI: Razer v: 1.02 date: 05/26/2020
Battery:   ID-1: BAT0 charge: 17.2 Wh condition: 52.8/53.4 Wh (99%) volts: 11.1/11.6
           model: Razer Blade type: Unknown serial: <filter> status: Discharging
CPU:       Topology: Quad Core model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake
           family: 6 model-id: 7E (126) stepping: 5 microcode: 78 L2 cache: 8192 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23968
           Speed: 746 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 850 2: 1170 3: 626 4: 926
           5: 682 6: 1236 7: 936 8: 727
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel Iris Plus Graphics G7 vendor: Razer USA driver: i915 v: kernel
           bus ID: 00:02.0 chip ID: 8086:8a52
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Razer USA driver: nvidia
           v: 450.66 alternate: nouveau,nvidia_drm bus ID: 58:00.0 chip ID: 10de:1f95
           Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo bus ID: 3-6:4
           chip ID: 13d3:56d5 serial: <filter>
           Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia unloaded: intel,nouveau
           alternate: fbdev,nv,vesa display ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
           s-diag: 582mm (22.9")
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 166 size: 294x165mm (11.6x6.5")
           diag: 337mm (13.3")
           OpenGL: renderer: llvmpipe (LLVM 10.0.1 256 bits) v: 3.3 Mesa 20.1.6 compat-v: 3.1
           direct render: Yes
Audio:     Device-1: Intel Smart Sound Audio vendor: Razer USA driver: sof-audio-pci
           alternate: snd_hda_intel,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:34c8
           Sound Server: ALSA v: k5.7.17-2-MANJARO
Network:   Device-1: Intel Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter driver: iwlwifi
           v: kernel port: 4000 bus ID: 00:14.3 chip ID: 8086:34f0
           IF: wlo1 state: up mac: <filter>
Drives:    Local Storage: total: 946.39 GiB used: 7.04 GiB (0.7%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB
           block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter>
           rev: 2B2QEXM7 scheme: GPT
           ID-2: /dev/sda type: USB vendor: Intenso model: Alu Line size: 14.88 GiB block size:
           physical: 512 B logical: 512 B serial: <filter> rev: 8.07 scheme: MBR
Partition: ID-1: / raw size: 931.22 GiB size: 915.60 GiB (98.32%) used: 7.04 GiB (0.8%) fs: ext4
           dev: /dev/nvme0n1p2
Swap:      Alert: No Swap data was found.
Sensors:   System Temperatures: cpu: 36.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 194 Uptime: 20m Memory: 15.38 GiB used: 755.1 MiB (4.8%) Init: systemd v: 246
           Compilers: gcc: 10.2.0 Packages: pacman: 1029 lib: 270 Shell: Zsh v: 5.8
           running in: urxvtd inxi: 3.1.05

does anyone know what is causing it or has an idea in which direction i can go?
thanks in advance

Don’t be afraid of the search function, it found this thread:

With a switch to kernel 5.8 as solution.

i tried switching to kernel 5.8 through manjaro-settings-manager and rebooting. I still see the issue and on top my system freezes for about 5 min. after every mouse move.
Do i have to somehow update my packages after switching kernels?

I noticed you have a Razer Blade Stealth 2020. This model is currently not working even with the latest kernel and i915/drm drivers, there is a bug report here:


that you could comment on to help us get attention to it and hopefully get it fixed.