Drive shows lock icon, even though permissions say read/write?

Got a NTFS drive attached to Manjaro xfce, however it continues to show the lock icon, and indeed if I try to edit a file, I get the access denied.

I have checked permissions and for all users read/write is enabled, however the lock icons persist. I have tried CHOWN and CHMOD commands and it makes no difference.

Is there a way to fix this that doesn’t mean I need to transfer all files somewhere (450+gig) then format drive to ext 4 and re-import?

Is it mounted readonly?

mount -l

If so, then that happens when the dirty bit is set for any reason. Can be removed with ntfsfix, but preferably you should run chkdsk on windows. However it is mounted readonly to avoid problems since it usually mean to be checked, but on linux there is no tool to check ntfs filesystems.

Thanks - no windows.

It is mounted. I’ll try ntfsfix.

got this:
Attempting to correct errors… Error opening read-only ‘/dev/nvme1n1p2’: Permission denied
Failed to startup volume: Permission denied
Error opening ‘/dev/nvme1n1p2’: Read-only file system
Volume is corrupt. You should run chkdsk.
it is a non-removable hard drive (well NVMe SSD really) - might just have to do the transfer data operation I think :frowning:

Those are utilities for changing the POSIX file ownership and permissions. NTFS is not a POSIX filesystem and does not support or store that kind of information. Please see… :arrow_down:

If an NTFS filesystem is mounted read-only in GNU/Linux, then it’s usually because it was used by Windows with the Windows fast boot (hybrid sleep) enabled, which does not properly shut down the filesystems. Upon trying to mount such a filesystem in GNU/Linux, the kernel will detect this open state as filesystem damage and will mount the filesystem read-only so as to prevent further damage.


Thanks much Aragorn…I’ll note that for future reference. I did find on one of the Linux reports it showed the disk as corrupt (even though I could access the data) …so I just did a transfer of the data to an external drive, deleted and re-established the drive under Gparted as EXT4, and transferred the data back…only took about an hour and a bit :slight_smile:

EDIT: That is some pretty intense stuff in those tutes! Lots over my head, but I get the general gist! That would have take you a long time to prepare those for everyone, so even though I daresay you’ve been thanked lots, add another one from me!


Followed the step by step here: How to set up a printer on Manjaro

Most of the software listed was installed - the one thing I forgot was to unlock the Printer Config box - it appears with an “unlocked” padlock, which cause me to think it was unlocked, BUT the article indicated that it was the opposite. Followed that step and the rest was easy.
Just printed a test page!

Thanks to all who gave advice, and so quickly as well!! Much appreciated.
I’ll mark the thread topic as solved , in case another has a similar issue.