Downloads folder missing in the leftmost pane

Hello,

The title says it all. The folder is visible in the middle pane.

Please, help.

You can drag the Downloads folder from the middle pane to the left pane.

It wants to merge, but does not allow me. Also, I do not see Music, Pictures directories. Again, when trying to copy them, I get a message they are there.

You’re not being very clear, but I presume you’re talking of either the file-open/save dialog and/or the file manager. In that case, the left pane does not show you all available/existing folders, but rather a “quick pick” list.

And while I myself am not using Cinnamon ─ I’m a Plasma user ─ I have also noticed the absence of the Downloads folder in the left-hand pane of the file-open/save dialogs of GTK-based applications ─ Cinnamon is a GTK-based environment ─ whereas earlier it used to be there.

I can only surmise that this was a decision made by the GTK developers upstream. :man_shrugging:

It was there!

Check your ~/.config/user-dirs.dirs and make sure the Downloads folder is there. It looks like this by default:

# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run.
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
# 
XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

sudo: /home/jojo/.config/user-dirs.dirs: command not found

It’s a file, not a command. NEVER use sudo in your Home directory.

Open Nemo (file manager) and enable Show Hidden Files in the View menu. Then navigate to the .config folder and open user-dirs.dirs in your favorite text editor.

Or view it from the terminal:

cat  ~/.config/user-dirs.dirs

I copied your default contents, but nothing happens.

I found a workaround:
Go to your home directory and drag with left mouse button downloads to the left pane where desktop, filesystem etc are.
After reboot it stays there on my machine

Edit: this is in nemo, i don’t know if this will work in open file dialogs as well

Thank you bikehunter, but I have tried this.

Happy New Year@

happy new year to all…
open a terminal and type:

pamac info xdg-user-dirs

seems to be missing in your installation?check, and install from pamac the relative packages if it is the case.

pamac reinstall xdg-user-dirs
pamac reinstall xdg-user-dirs-gtk
xdg-user-dirs-update

Thank you Manyaro01. I was laying reat expectations on your answer, but everything is of old.
~https://imgur.com/a/rmKK1GH~

as an example:

https://forums.linuxmint.com/viewtopic.php?t=237988

pd: your image is not visible

pamac info xdg-user-dirs~
Error: target not found: xdg-user-d