Download Speed is OK But Web performance is bad

Hello everyone I have wifi connection and speed is 20 mbps. It works fine during download etc. But I can not connect to somewebsites or it takes significant time to connect. Myphone is also connected to the same wifi I have not such issue.
Systemd resolver

 Protocols: +LLMNR +mDNS -DNSOverTLS DNSSEC=no/unsupported
    resolv.conf mode: foreign
  Current DNS Server:
         DNS Servers:
Fallback DNS Servers:
          DNS Domain: Wireless-N

networkctl status -all

systemd-networkd is not running, output might be incomplete.
Failed to query link bit rates: Could not activate remote peer: activation requ>
Failed to query link bit rates: Could not activate remote peer: activation requ>
Failed to query link DHCP leases: Could not activate remote peer: activation re>
● 1: lo
                   Link File: n/a
                Network File: n/a
                       State: n/a (unmanaged)
                Online state: unknown
                        Type: loopback
            Hardware Address: 00:00:00:00:00:00
                         MTU: 65536
                       QDisc: noqueue
IPv6 Address Generation Mode: eui64
    Number of Queues (Tx/Rx): 1/1
Failed to query link DHCP leases: Could not activate remote peer: activation re>

Hello @karakobra1 :wink:

Probably because Manjaro has no DNS Cache by default and requests every IP of any Domain every time.

File: /etc/NetworkManager/conf.d/dns.conf


Then reload the config:

sudo nmcli general reload

Test it:


Take look at query time and the server must be now:

1 Like

This looks like a custom dns - not even a router - but definately something custom.

You need to retrace your changes to get back to a working system

yes it is so can you explain me whay we’ve done here and also is this aproblem ```
systemd-networkd is not running, output might be incomplete.

how can I retrace the changes?

only you know … what changes you may have made … but it most likely connected to your DNS - perhaps a half configured or broken VPN tunnel

NetworkManager is the default on Manjaro and systemd-networkd is another network service. Both conflict with each other, so only one can run.


Manjaro doesn’t use systemd-resolved, it uses the glibc resolver.

Post output of nmcli device show.

GENERAL.DEVICE:                         wlo1
GENERAL.TYPE:                           wifi
GENERAL.HWADDR:                         80:32:53:78:9C:27
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.CONNECTION:                     wifiname1
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveC>
IP4.ROUTE[1]:                           dst =, nh =, mt >
IP4.ROUTE[2]:                           dst =, nh =, mt>
IP4.DOMAIN[1]:                          Wireless-N
IP6.ADDRESS[1]:                         fe80::3257:5a80:19d6:9e79/64
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = fe80::/64, nh = ::, mt = 1024

GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536
GENERAL.STATE:                          100 (connected (externally))
GENERAL.CONNECTION:                     lo

Are you using some ancient router? Wireless-N is from 2008 and you don’t even have IPv6 support.

Post output of inxi -nz.

Also drill and same again for a website that you have problems connecting to.

  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi
  IF: wlo1 state: up mac: <filter>

output of inxi

My guess is that the problem is a crappy DNS server on the router. I don’t why your phone works ok with it, perhaps you changed DNS servers on that in the past? You can manually set DNS servers for your connection like this;

nmcli conn modify “wifiname1” ipv4.ignore-auto-dns yes
nmcli conn modify “wifiname1” ipv4.dns “”
nmcli conn down “wifiname1”
nmcli conn up “wifiname1” = Cloudflare = Google

If you don’t want to use them then use your ISP’s dns server addresses instead.

ok then all the information revelead by systemd-resolver is useless in this case as well as etc/resolv.conf right?

I think Android uses a Google-powered DoH server (If I recall that correctly) for DNS, unless you change and customize it. So it might be that. I don’t know if it’s the same for iOS or not.


No, but etc/resolv.conf is managed by Network Manager so don’t edit it directly.

That would make sense.

It would yes. I know I had to customize my settings for it so that it used my PiHole instead of Google’s thing.

thanks btw it seems running better now, is there a resource that I can learn more about linux networking and commands etc. ?

The Archwiki is your friend:

thx for example is there a way to find out which network manager is used

As far as I know, by default Manjaro uses NetworkManager and resolvconf. But I don’t know other than knowing your system. (In this case, the defaults. Don’t worry, I’m using the defaults myself.)