Downgrading to nvidia 390

I’m trying to play Doom Eternal, the game crashes before the main menu with VRAM allocation problem.

I’m running a 1050ti with Proprietary Nvidia driver 495.46
This is a common issue and the solution is to downgrade to Nvidia 390.

When I try using the “Hardware Configuration” tab in the settings to install nvidia 390 I get error

Error: config 'video-nvidia-390xx' conflicts with config(s): video-nvidia

I fixed this issue successfully one time, where I went into pamac and manually installed the package for nvidia 390 and then mhwd was able to install it…

Recently underwent an upgrade from an AMD FX 6300 to Ryzen 1600 and a software update pushed me onto the latest drivers.

Now, when I try my previous fix, it bricks my driver setup (stuck on boot at “reached target display manager”), and I need to uninstall video-nvidia-390xx and go back to video-nvidia(latest version).

Am I doing something wrong? Is there a better way? Thank you for your time.

Remove video-nvidia first then install video-nvidia-390xx:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

This worked! Thank you! Command line is always the answer, I guess…

Isn’t the 470 driver working? The 390 driver is very old, considered garbage especially for gaming, it doesn’t properly support everything you would need to play games especially Windows games with Proton.

I don’t have time to test it right now. I chose 390 because its what has been working for me…
I will report back with my results.

470 works. Although I now have a screen tearing issue that might be unrelated.

You need to enable Compositing Pipeline in Nvidia Advanced Settings I guess (I do FULL but you can just do basic, not FULL composition pipeline). Also reopen Nvidia Settings with sudo command after configuring it, and save the settings to the Nvidia config file /etc/X11/mhwd.d/nvidia.conf so they are applied system wide and properly load with the system every time.

This is what I’m talking about (don’t exactly follow it, it is only to picture what I’m talking about) Fix screen tearing on KDE with Nvidia - Album on Imgur

It needs a reboot to properly apply these settings.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.