It’s been suggested that a fix for a problem I’m having with darktable on Manjaro XFCE is to downgrade the lua package. I’ve never done this before, and wonder what risks it presents, and if there is anything I should do before attempting this (other than a Timeshift snapshot).
Thanks for any insights you can offer.
If you installed darktable from repo, then you already have lua53 - it’s darktable’s dependency.
Although I did install darktable from the repro, my system has 5.4 installed:
pamac info lua
Name : lua
Version : 5.4.3-1
Description : Powerful lightweight programming language designed for
URL : https://www.lua.org/
Licenses : MIT
Repository : extra
Installed Size : 1.2 MB
Depends On : readline
Required By : gnuplot gpick
Optional For : graphviz hexchat
Packager : Anatol Pomozov <firstname.lastname@example.org>
Build Date : 03/29/2021
Install Date : 04/24/2021
Install Reason : Installed as a dependency for another package
Signatures : Yes
I see in the Pamac GUI that darktable has a dependancy on lua 5.3, and offers the option to reinstall it. Is this a possible fix?
It doesn’t have a dependency on lua=5.3, it has a dependency on lua53. It’s a standalone package. And you already have it, so reinstalling won’t do you much. Whatever problem you are having this is not the fix you are looking for.
You have lua5.3 but lua is linked to lua5.4. I don’t know darktable but you can call lua5.3 or change lua to call lua5.3 instead of lua5.4 (which is the default).
Thanks for the clarification.
The problem is that the lightable module crashes when scrolling.
If started from the terminal, I get an error message:
PANIC: unprotected error in call to Lua API (error in __gc metamethod (Destroying a widget which is still parented, this should never happen (check_button at 0x5637ecc43760)
Aborted (core dumped)
One of the guys on PIXL.US suggested it might be because of the lua 5.4 I have installed.
“DT requires lua 5.3, perhaps you can try with that”