Downgrade Kernel to make VirtualBox work


I was using the Kernel 6.3.0 because with this one I was able to use Virtual Box (details here) but my kernel has been upgraded to 6.3.4-2 and Virtual Box doesn’t work anymore :frowning:

How can I get back to 6.3.0?

By the way in the GUI I don’t see any button to “use” a different kernel anymore. I could use some support :slight_smile:. Thanks!

edit: corrected the link to the first post of the thread

You can’t.

What is the actual problem? Did you reboot?

1 Like

Since the upgrade I’m facing the same issue as in this post. The VM stays on the screen saying “VM starting”. I tried to reboot yes.

If I can’t downgrade the 6.3 I could try 6.2 or the updated 6.1 but I don’t know how to do it in GUI and maintaining shift key doesn’t work. I also tried /etc/default/grub

sudo update-grub

but grub doesn’t show.

Press ESC several times while booting and Grub menu will appear.

1 Like

Thanks. I tried

  • 6.3,
  • 6.2.0_rt,
  • 6.2.16,
  • 6.1.30

and it’s KO.

I’m a bit afraid of testing 5.19 as it seems unsupported. Could you confirm I can try this one too?

You should remove 5.19 from the system (it’s EOL since 6.1 came) as that’s only going to make issues with updates.
Try LTS ones, 5.15, 5.10.

1 Like

Thanks it worked with the 5.15.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.