Downgrade binutils to 2.34-4 or lower

There is an issue with the current binutils version 2.35-1 which keeps chromium from building with ffmpeg. See: bugzilla redhat com/show_bug.cgi?id=1869884
In my case I am trying to build QT 5.15.2 which fails because of this issue. (I realize that QT 5.15.2 is in the repositories, but our build system is not set up to use system QT as we have always needed patches)

The downgrade package does not seem to be in the aarch64 repositories and I cannot find an old package anywhere.

The qt 5.15.2 we have in the repo, is built using the libraries in the repo, so it does build.

Correct, we don’t have this package, since it’s not in Arch Linux ARM, but meant for Arch.
@cscs made a script/fork (MLA) some time ago, which supported aarch64, but I think the project has stopped because of too little interest.

I tried it two times (second time I tried to disable ffmpeg in chromium which didn’t work out) and it failes because of this issue. Do the QT packages in the repo not include qtwebengine?

Actually you can also build chromium with system ffmpeg, so it could also be built using the ffmpeg in the repo.

There’s a package called qt5-webengine if that’s what you mean?

Well anyways, none of this changes the original problem. I cannot build QT with this version of binutils and that is a known issue, at least on the redhat bugtracker where they also got a patch.
So is there like a package archive like on archlinux where one could get an old version from?

1 Like

Sure, but remember if you downgrade binutils, you need to also downgrade gcc and all the stuff that’s built with gcc… Which is a lot.

I think the question still remains: Why can’t you build QT with the new binutils, when clearly Arch Linux ARM and we can…?

Downgrading to 2.34-2 did indeed fix QTWebEngine not building. There was no conflicts when installing that package as well.
Debian Bullseye also comes with the same binutils version also suffering from the same problem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.