Double-click delay

My mouse is buggy and I tried everything to set a delay for left click…

  • I switched to evdev and set an interval in the mouse settings, but it seems to only work in Dolphin
  • I put gtk-double-click-time=1000 in ~/gtkrc-2.0

But I don’t think it works correctly, I want it globally, even Wine apps, but I have no idea how.

This seems to solve my problem but it’s only for ubuntu, I’m not sure how to do it, please help me

We need from you to share this information from your terminal, as formatted text:

inxi -Fazy

xinput --list|grep pointer

If the xinput gives an error, or command not found, install xorg-xinput package, then run the command again. Once we have that information we can move on.

xinput --list|grep pointer

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech G203 LIGHTSYNC Gaming Mouse      id=10   [slave  pointer  (2)]
⎜   ↳ Logitech G203 LIGHTSYNC Gaming Mouse Keyboard     id=11   [slave  pointer  (2)]

Ok, now please share:
xinput --list-props 10|grep Debounce

1 Like

No return?
   ~  xinput --list-props 10|grep Debounce  INT ✘
   ~ 

I’m still with evdev , not with libinput
If that has anything to do with

Well, the xf86-input-evdev is a bit outdated and i think for your use case, you should use Piper to set up the Logitech G203 LIGHTSYNC Gaming Mouse.

pamac install piper

You will have more control in setting thing up instead of a solution from 4 years ago. Se more about Piper here

1 Like

Done. I’m back to libinput too.

   ~  xinput --list-props 10|grep Debounce  :heavy_check_mark:
   ~ 

(there’s a checkmark now)

ratbagd is running

There seems to have been a noticeable improvement, I don’t know if it’s because of Piper or what, because previously I was using libinput.
Although the problem has not been completely solved, I would like to know if debounce is really activated, or if I can configure it?
Anyway I will mark as a solution, thanks!

All goes trough libinputlibevdev + xf86-input-evdev + libratbag
libratbag is the one that is used by Piper …
As described in the link you provided, now you can create a file in /usr/share/X11/xorg.conf.d/99-logitech.conf for example, and add

Section "InputClass"
    Identifier "evdev-mouse-logitech"
    MatchProduct "Logitech G203 LIGHTSYNC Gaming Mouse"
    MatchIsPointer "on"
    Driver "evdev"
    Option "DebounceDelay" "20"

Or at least i think so … the device id is already provided libratbag/logitech-g102-g203.device at master · libratbag/libratbag · GitHub wne you installed Piper, and see what value is proper for you if 20 is not ok.


Thank you for your time, have a nice weekend

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.