Dotnet Core on Manjaro ARM

My first concern is with the Pinebook Pro, but I suppose this goes for virtually any Manjaro ARM device.

I’ve been trying to get .NET Core running on my Pinebook Pro. I thought I had it running on a previous installation, but I am having difficulties getting it to work after performing a reinstallation after having issues with a prior update.

Getting .NET to work via Mono is simple, but I’m not sure if this version of Mono is using a wrapper on .NET Core or not (I vaguely remember this being mentioned before).

I’ve tried the snap installation, but it does not appear to work; it does not set up any aliases, and trying to run the executable directly gives me a “file or directory not found” message.

The AUR packages seem more promising, however one of the dependencies is still explicitly looking for an AMD64 or x86 version, despite supposedly supporting aarch64.

On Microsoft’s end, they definitely support AARCH64 now.

I’'m going to try to install from their install scripts or binaries (though the latter always feels a bit ugly to me if it’s not coming from a package manager) but I was curious if anyone had luck with any particular method.

Edit: NVM on the script; it’s more for usage cases involving continuous integration.

I am deep into a project right now which needs a desktop client and I just learned that some Surface tablets are using ARM so yes it is possible - but you may have to download it from Microsoft - or build it from AUR.

Latest 5.0.1 from AUR

pamac build dotnet-host-bin dotnet-runtime-bin dotnet-sdk-bin dotnet-targeting-pack-bin

Or install 3.1 from the repos

pamac install dotnet-host dotnet-runtime dotnet-sdk dotnet-targeting-pack

Yea, someone updated it on the AUR, which is great. I had forgotten about this thread. After the most recent update, something required .NET Standard, which reminded me to look for .NET Core again.

Appreciate it!


I have .NET on my Pinebook Pro usine AUR package: dotnet-sdk-bin.
Admittedly I only briefly tested it with some small F# programme, but that worked.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.