Don't know where to find hibernate to disable it. Changing power settings didn't do anything for me

How do I turn off hibernate? Clearly I followed one guy on YouTube, and all he did was go into power settings, and I copied the few things he did and save. But when I reboot my computer, everything I had open is open. I wanna disable it cuz I’ve had performance issues with my RAM. I heard disabling hibernation and adjusting swappiness is a good idea. Can I only do it in the terminal? if so, I once again ask how?

Try this:

sudo nano /etc/systemd/sleep.conf.d/no-hibernate.conf

paste the following in there save and exit.

# disable hibernation
# doc :

Once you reboot the hibernate option should be gone.


I get this error when I nano in " No such file or directory"

Which directory is “missing”


do this first:

sudo mkdir /etc/systemd/sleep.conf.d

1 Like

thank you very much! worked perfectly

Is there a similar solution for no-sleep (in the Plasma menu Suspend to RAM)?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.