Don't know how to install Davinci Resolve properly

Hello everybody.

I tried to install davinci-resolve following all instructions from Arch Wiki, but I was unsuccessful. I installed amdgpu-pro-libgl and opencl-amd package, when I try to install davinci-resolve from AUR, it installs perfectly, and also starts, I get to the project creation screen, but I can’t get past that. When I try to create a project, the program loads, loads, and nothing happens, when I try to click “Open” in the initial project that Davinci creates by default, nothing happens either. I also took care to uninstall opencl-mesa as I am using opencl-amd.

The Archwiki page says “Requires running Resolve with the progl wrapper script. See documentation.” How do I do this? Where is the documentation?

I’ve tried the command progl davinci-resolve but it says: /usr/bin/progl: line 30: davinci-resolve: command not found, even though I already have the davinci-resolve package installed.

I installed davinci-resolve-checker program to check if the computer is able to run davinci, the program says:

'/home/denielton/Downloads/davinci-resolve-checker-master/davinci-resolve-checker.py'
DaVinci Resolve checker 1.6.2
Installed DaVinci Resolve package:
Chassis type: desktop
Installed OpenCL drivers: opencl-amd
Gifted GPUs:
Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (driver kernel in use: amdgpu)
OpenGL vendor string: AMD

You are not using Pro OpenGL implementation. Install amdgpu-pro-libgl and run DaVinci Resolve with progl prefix. Otherwise it will crash.

However, the amdgpu-pro-libgl package is installed.

The versions of the package that are installed on my computer are the same ones that are working with DR, according to Arch Wiki.

yay -Ss amdgpu-pro-libgl
aur/lib32-amdgpu-pro-libgl 21.30_1290604-1 (+104 0.79)
     AMDGPU Pro OpenGL driver (32-bit)
aur/amdgpu-pro-libgl 21.30_1290604-1 (+104 0.79) (Installed)
     AMDGPU Pro OpenGL driver 
yay -Ss opencl-amd
aur/xmr-stak-opencl-amd 2.10.8-1 (+2 0.00) (Orfão) 
    Unified All-in-one Monero miner (AMD)
aur/opencl-amd 21.30.1290604-1 (+106 1.87) (Installed: 21.10.1247438-1)
    OpenCL userspace driver as provided in the amdgpu-pro driver stack. This package is intended to work along with the free amdgpu stack.
inxi -Fxz
System:
  Kernel: 5.10.59-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  Desktop: GNOME 40.3 Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-GAMING/BR v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2006 date: 11/13/2019 
CPU:
  Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ 
  rev: 2 cache: L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 81467 
  Speed: 2164 MHz min/max: 1550/3400 MHz boost: enabled Core speeds (MHz): 
  1: 2164 2: 1286 3: 3853 4: 1557 5: 1363 6: 1552 7: 3772 8: 1556 9: 1996 
  10: 1370 11: 1374 12: 1556 
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: XFX Pine driver: amdgpu v: kernel bus-ID: 08:00.0 
  Device-2: A4Tech REDRAGON Live Camera type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 3-2:2 
  Display: x11 server: X.Org 1.20.13 driver: loaded: amdgpu,ati 
  unloaded: modesetting resolution: 1920x1080~70Hz 
  OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.40.0 
  5.10.59-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.1.6 direct render: Yes 
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 08:00.1 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 0a:00.3 
  Device-3: A4Tech REDRAGON Live Camera type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 3-2:2 
  Sound Server-1: ALSA v: k5.10.59-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000 
  bus-ID: 07:00.0 
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 447.13 GiB used: 96.4 GiB (21.6%) 
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB 
Partition:
  ID-1: / size: 48.97 GiB used: 32.35 GiB (66.1%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot/efi size: 269.5 MiB used: 312 KiB (0.1%) fs: vfat 
  dev: /dev/sda1 
  ID-3: /home size: 389.64 GiB used: 64.05 GiB (16.4%) fs: ext4 
  dev: /dev/sda3 
Swap:
  ID-1: swap-1 type: file size: 1024 MiB used: 0 KiB (0.0%) file: /swapfile1 
Sensors:
  System Temperatures: cpu: 39.4 C mobo: N/A gpu: amdgpu temp: 39.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1108 
Info:
  Processes: 320 Uptime: 25m Memory: 15.62 GiB used: 3.78 GiB (24.2%) 
  Init: systemd Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1356 
  Shell: Zsh v: 5.8 inxi: 3.3.06 

Thank you for your attention.

Probably because davinci-resolve is not the right command. You can try progl /opt/resolve/bin/resolve or progl resolve

1 Like

progl /opt/resolve/bin/resolve make it work LETS FXCKING GOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.