Dolphin using up two full cpu cores

Good evening,
I have a Problem with my Dolphin file manager. Sometimes its CPU usuage rises up to 200%, using up two out of eight Threads. It stays that high for 15-30 Minutes. Is this normal? Maybe its doing something in the background? I tried to google this but didn’t find anything on this topic.

Has anyone else experienced this? If yes, how did you fix it?

My System Information:

Kernel: 5.15.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0                                                                                                                      
parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64                                                                                                                                     
root=UUID=085e8557-1b10-4f71-9499-be3bbf6ebfcc rw quiet apparmor=1                                                                                                                   
security=apparmor resume=UUID=9fd42a05-4f18-4d36-9e43-26236a1dcb9e                                                                                                                   
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM                                                                                                                   
Distro: Manjaro Linux base: Arch Linux                                                                                                                                               
Type: Laptop System: HP product: HP 250 G7 Notebook PC
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 8532 v: 70.31 serial: <superuser required>
UEFI-[Legacy]: Insyde v: F.23 date: 11/29/2019
ID-1: BAT1 charge: 36.5 Wh (100.8%) condition: 36.2/41.9 Wh (86.4%)
volts: 12.9 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion
serial: <filter> status: N/A
RAM: total: 15.52 GiB used: 10.53 GiB (67.9%)
RAM Report:
permissions: Unable to run dmidecode. Root privileges required.
Info: model: Intel Core i7-8565U bits: 64 type: MT MCP
arch: Comet/Whiskey Lake note: check family: 6 model-id: 0x8E (142)
stepping: 0xC (12) microcode: 0xEA
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1202 high: 2429 min/max: 400/4600 scaling:
driver: intel_pstate governor: powersave cores: 1: 967 2: 856 3: 1678 4: 948
5: 864 6: 955 7: 924 8: 2429 bogomips: 32012
Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida
intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp
rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: TSX disabled
Type: tsx_async_abort status: Not affected
Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Hewlett-Packard
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300
Device-2: ARC Camera type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-3.1:11 chip-ID: 05a3:9331 class-ID: 0102 serial: <filter>
Device-3: Cheng Uei Precision Industry (Foxlink) HP Webcam type: USB
driver: uvcvideo bus-ID: 1-5:5 chip-ID: 05c8:0238 class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org compositor: kwin_x11 driver:
loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 4262x1080 s-dpi: 96 s-size: 1124x285mm (44.3x11.2")
s-diag: 1160mm (45.7")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142
size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
Monitor-2: HDMI-1 res: 1680x1050 hz: 60 dpi: 267 size: 160x90mm (6.3x3.5")
diag: 184mm (7.2")
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.3.5
direct render: Yes
Device-1: Intel Cannon Point-LP High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:9dc8 class-ID: 0403
Device-2: ARC Camera type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-3.1:11 chip-ID: 05a3:9331 class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.15.21-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.20 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.45 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus-ID: 01:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
IP v4: <filter> type: dynamic noprefixroute scope: global
broadcast: <filter>
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:c821 class-ID: 0280
IF: wlo1 state: down mac: <filter>
WAN IP: <filter>
Message: No bluetooth data found.
Message: No logical block device data found.
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 5060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Local Storage: total: 3.21 TiB used: 1.67 TiB (52.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN520 SDAPNUW-512G-1006 size: 476.94 GiB block-size:
physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
serial: <filter> rev: 20120006 temp: 44.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MK5065GSXF
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: 8B scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Apacer model: AS350 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3PE0 scheme: MBR
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
model: WD2000FYYZ-01UL1B1 size: 1.82 TiB block-size: physical: 512 B
logical: 512 B type: HDD rpm: 7200 serial: <filter> scheme: MBR
Message: No optical or floppy data found.
ID-1: / raw-size: 468.13 GiB size: 459.72 GiB (98.20%)
used: 188.08 GiB (40.9%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: N/A
uuid: 085e8557-1b10-4f71-9499-be3bbf6ebfcc
ID-2: /run/media/gregor/669254219253F451 raw-size: 476.31 GiB
size: 476.31 GiB (100.00%) used: 232.41 GiB (48.8%) fs: ntfs
dev: /dev/nvme0n1p4 maj-min: 259:4 label: N/A uuid: 669254219253F451
ID-3: /run/media/gregor/New Volume raw-size: 1.1 TiB
size: 1.1 TiB (100.00%) used: 727.96 GiB (64.5%) fs: ntfs dev: /dev/sdc1
maj-min: 8:33 label: New Volume uuid: 9C76DC3076DC0CC0
ID-4: /run/media/gregor/Volume raw-size: 465.76 GiB
size: 465.76 GiB (100.00%) used: 268.3 GiB (57.6%) fs: ntfs dev: /dev/sda1
maj-min: 8:1 label: Volume uuid: AC8CBF3A8CBEFE40
ID-5: /run/timeshift/backup raw-size: 698.39 GiB size: 686.36 GiB (98.28%)
used: 291.92 GiB (42.5%) fs: ext4 dev: /dev/sdc2 maj-min: 8:34 label: N/A
uuid: ce09d192-f560-4814-80e5-7f53c86adbef
Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 2.29 GiB (26.0%)
priority: -2 dev: /dev/sdb2 maj-min: 8:18 label: swap
uuid: 9fd42a05-4f18-4d36-9e43-26236a1dcb9e
ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 529 MiB fs: ntfs
label: Wiederherstellung uuid: CEF24EABF24E981B
ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 100 MiB fs: vfat label: N/A
uuid: 364F-7BD7
ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 16 MiB fs: <superuser required>
label: N/A uuid: N/A
Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
Hub-2: 1-2:2 info: Terminus Hub ports: 4 rev: 2.0 speed: 480 Mb/s
power: 100mA chip-ID: 1a40:0101 class-ID: 0900
Device-1: 1-2.1:4 info: XP-Pen STAR G640 type: Mouse,HID
driver: uclogic,usbhid interfaces: 3 rev: 1.1 speed: 12 Mb/s power: 70mA
chip-ID: 28bd:0094 class-ID: 0300
Device-2: 1-2.2:10 info: Pixart Imaging Optical Mouse type: Mouse
driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
power: 100mA chip-ID: 093a:2510 class-ID: 0301
Device-3: 1-2.3:8 info: Canon CanoScan LiDE 50/LiDE 35/LiDE 40
type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s
power: 500mA chip-ID: 04a9:2213 class-ID: ff00
Device-4: 1-2.4:9 info: HP Deskjet 1510 type: Printer driver: usblp
interfaces: 3 rev: 2.0 speed: 480 Mb/s power: 2mA chip-ID: 03f0:c111
class-ID: 0701 serial: <filter>
Hub-3: 1-3:3 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s
power: 100mA chip-ID: 05e3:0610 class-ID: 0900
Device-1: 1-3.1:11 info: ARC Camera type: Video,Audio
driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
power: 200mA chip-ID: 05a3:9331 class-ID: 0102 serial: <filter>
Device-2: 1-3.2:6 info: SZH usb keyboard type: Keyboard,HID
driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
power: 98mA chip-ID: c0f4:05c0 class-ID: 0300
Device-3: 1-5:5 info: Cheng Uei Precision Industry (Foxlink) HP Webcam
type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s
power: 500mA chip-ID: 05c8:0238 class-ID: 0e02 serial: <filter>
Hub-4: 2-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
chip-ID: 1d6b:0003 class-ID: 0900
Device-1: 2-1:2 info: ASMedia ASM1153 SATA 3Gb/s bridge type: Mass Storage
driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s chip-ID: 174c:1153
class-ID: 0806 serial: <filter>
System Temperatures: cpu: 62.0 C pch: 48.0 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Processes: 314 Uptime: 11h 31m wakeups: 1 Init: systemd v: 250
tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.1 Packages: 2414 apt: 0
pacman: 2304 lib: 441 flatpak: 68 snap: 42 Shell: fish v: 3.3.1 default: Zsh
v: 5.8 running-in: yakuake inxi: 3.3.12

Also i’m using dolphin 21.12.2

Thank you for your help

first of all, this is helpful

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


1 Like

Disable Baloo.


Thank you both for your replies, i edited in my System info.

I don’t think its the baloo indexer, i already deactivated that one and baloo was usually running in a different process. Or does it affect dolphin indirectly? Anyways i have baloo turned off.

Its not really a big problem as restarting dolphin usually fixes it for some time, but i would really like to find out what causes this :slight_smile:

1 Like

Type the following one at a time into a terminal and see what you get back. Baloo is not that easy to kill sometimes.

balooctl disable
balooctl purge
balooctl suspend
balooctl status

Also have you tried checking with htop for example to see what is using the resources?

1 Like