Dolphin. Thumbnails dont seem to work nowadays

I use thumbnails quite a lot on dolphin in my pic folder but recently i have noticed a lot of them just dont show up. Also the “information” side panel does not show the thumbnail pics either?

Even the browser selector is not showing the thumbnails on the right hand side (this is me hover over a file)

Maybe the files are too big for what is set in the Dolphin preferences?

Na, all the ones that cant produce a thumb are all at the top and some are very small in size.

God this is hard without being able to show a Screenshot :angry:

Everything below here is thumbnail, everything above is just purple icon. Hovering over the file also does not produce a thumbnail on the “information” bar on the right either

wow, Thank you whoever allowed me to be able to post link ^^

Those are all PNG files. You probably don’t have previews enabled for .png.


It’s because you’ve reached TL1 status. You were a TL0 before, and TL0s can’t post pictures. :wink:

sorry what do you mean, they are all .png in the screenshot, some are showing thumbnails fine others (at the top) are not, but they are all .png Regardless it does the same with .jpg anyhow.

Have you tried moving them to another folder, then opening that folder in the file manager, and then moving them back? Sometimes it takes some effort to get Dolphin to rebuild the thumbnail cache.

iv tried moving things, different folders, switching the thumbnails off/on just about everything i can think of.

Here the same effect in a dif folder with .jpgs’s

Also here’s my file upload selector where i can usually see the pic’s on the right hand side when i hover over them before i select them but not any more.

Dolphin always shows the .png preview / thumbnail by default.

I’d try is opening them in Gwenview which I believe is already installed, or installing Kolourpaint and see if you can view them in those apps.

After the last update, the limit for displaying dolphin thumbnails was set at 3 Mb. You can change it in the Dolphin settings.

3 Likes

Yea these folders all work and display fine in Gwenview and Kolourpaint.

Sorry, where is that ? It says “Skip previews for remote file above”. These are not remote and i assume 0Mb means zero limit.

Ah ha ! I clicked on “default” on the dolphin setting window (even though i haven’t changed this settings page ever) and now everything is working again

  • I’ve got all the thumbnails working straight off (as soon as i open the folder)
  • I’ve got the little special folder containing pics icons for my folders
  • ZZ_20200827-194504
  • and I’ve got the “information” side bar showing the preview properly now.

Just had to “reset” to default and reboot system and boom. Nothing changed in these setting but it must have reset something somewhere that some update might have messed up sometime.

Thank you all :smiley:

1 Like

Thank you! Just came to the forums looking for a solution because I thought recent updates broke stuff because only some photos were available for preview.

increasing the size helps with pictures, but I don’t get any thumbnails for video files since that update a few weeks ago, no matter if I check ffmpegthumbs in the list or not.

Did you try setting it to “no limit”?

I don’t see that option. But I’ve set it to 99999MB, which is far larger than any video file on my filesystem.

Where it says: “Skip previews for local files above” I can use the down arrow, and when it goes below 1 MB it says “No limit”. Anyway, I hope the problem is fixed on your side either way.

ah, thanks for the explanation. now I found the setting. its a bit strange that 0 means no limit for local and no thumbnails at all for remote locations. I understand the logic, still it feels very inconsistent.

So I guess ffmpegthumbs broke somehow for me…

UPDATE: so I’ve got an idea, possibly the reason is because I never reboot my laptop but only put it in standby when I don’t use it for a few hours (like when I sleep ^^)

So I probably didn’t reboot after installing that update that changed the thumbnailing in dolphin, so maybe rebooting will help.

$ uptime
 21:26:14 up 20 days, 12:09, 12 users,  load average: 2,58, 3,02, 3,19

Did you try the trick with selecting defaults and rebooting as @jackdinn wrote above? Other than that you might be able to find some guidance in the old forum (not active anymore) as well: Check out Search results for 'thumbnails dolphin' - Manjaro Linux Forum.