Dolphin freezes after a network change - Nautilus does not

I am struggling with what appeared to be a simple and common problem but I could not find an answer that worked for me, hence this post.
System: Lenovo Thinkpad W520 running Manjaro KDE
Problem: I have a NAS that I access with a cifs mount line in fstab. This works fine upon boot (I am on a LAN). Now I put the laptop to sleep, disconnect the LAN cable, wake up the laptop and connect to wifi. When I open Nautilus I can access all my drives. However when I open Dolphin it hangs. No drive, local or remote - can be accessed. I need to reboot, connect to wifi and then open Dolphin for it to work.
TIA - Ram


What DE is your default since you mentioned Doplhin and Nautilus ?

Oops - sorry I forgot to mention it. It’s in the main post now - Lenovo W520 with Manjaro KDE

Set your Dolphin preferences to open in your home folder instead of remembering the open folders like this:

Does it still happen then???


No it does not freeze then, thank you Fabby. So that does away with the comparison with Nautilus which would be meaningless :-). So what is the best way to manage the mapping/remapping to the NAS drive when I change my network connection? I did try sudo mount -a after the network change in an attempt to remap the NAS but that does not seem to work or seems to take a very long time - should I remove the noauto option in the fstab line?
Ideally what I would like to do is (a) To find out how to effect the remap quickly and (b) To be able to set up a timeout for the NAS drive so that Dolphin does not freeze but merely gives up after a user-specified time of say 5 or 10s and either gives me a message or allows me to choose another folder (Home) . That would be preferable to setting the Home folder as startup default.
Currently the fstab line reads as follows:
// /mnt/ramkumarrNAS cifs _netdev,noauto,x-systemd.automount,nofail,x-systemd.device-timeout=10ms,username=ramkumarr,password=19661547,vers=1.0,uid=1000,gid=1000,iocharset=utf8 0 0
Best - Ram

Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

You should remove this:

DDG for “TCP/IP time-out” but lowering it too much will start giving you other errors if there is a glitch in your router / network, so I’d keep the solution you have…

Many thanks Fabby. Will remove nofail and go with your suggestions for now. Yes, I will eventually mark the best one (for me) as the solution just in case there are more ideas from anyone…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.