Dolphin FM not displaying "Mount" option when right clicking on ISO files

Hello Manjaro community, this is the first time in my entire life, asking for help on forums, am not a very technical Arch Linux user, but i learned a couple things along the way, anyway i need help this time, that’s the reason that i decided to make accounts in Linux Forums, to get through this:

Well, i use KDE Plasma, i have Dolphin FM, i’ve installed dolphin-plugins as always to be available to mount ISO files, but i recently installed Arch Linux again with all the dolphin necessary dependencies and it doesn’t display the “Mount” option when i right click on an ISO file.

i’ve already checked the option in the dolphin configuration in the “context menu” section, in fact its is checked by default, i tried downgrading dolphin and dolphin-plugins… nothing, i tried delete dolphin and re-install it… nothing.

It looks like the latest dolphin or dolphin-plugins version is broken or idk… who knows… the only way that i got it woking on Arch Linux is through flatpack i mean, the flatpack version of dolphin that everyone can get from discover, which is the crappiest version of dolphin btw. Anyway i don’t know how to workaround this if you can give me some tips please i’ll appreciate it…

Hi there,
Are you using Arch or Manjaro?
Maybe we can start with the output of the following, to show general system information
(and hide sensitive bits) :

inxi -Fazy

A guide here:

Welcome to the forum! :vulcan_salute:

First of all, just to get this out of the way, you are repeatedly referring to Arch Linux, but Manjaro isn’t Arch. Yes, it is Arch-based, but the versions of the software in Manjaro Stable lag behind on Arch Stable, because Manjaro is a curated rolling-release distribution. Version-wise, Arch Stable corresponds to Manjaro Unstable.

Secondly, never replace a system component by a FlatPak, Snap or AppImage. So remove that Dolphin FlatPak and reinstall dolphin from the repository.

Thirdly, you may need the kio-extras and kio-fuse packages from the repository.

I’m an Arch Linux user, idk exactly what do you mean by that, that peace terminal input right there “inxi -Fazy”, idk what’s that i’ve never use it, but if you can get me some feedback on how can i provide a log about what is happening which i think, it would be difficult because is just the fact that the option is no even showing, i mean the “mount” option, so how can i describe why wrong with dolphin or dolphin-plugins or plasma itself?

I want you to copy the command, paste it into terminal, hit enter, copy the output, and paste it here.

(please see the linked post for more information on how to share info, etc)

thank you i will try the kio-extras, and the kio-fuse pkgs, sorry for not clarifying that i’m not using manjaro, am an Vanilla Arch user, but it’s difficult to find info outside of forums without asking specifically but i guess you guys not mind that i don’t Manjaro, cause i know it’s confusing

Well, strictly speaking, we do — read the forum rules. This here is the official Manjaro community support forum. But given the similarity between Manjaro and Arch, we might still be able to help you out. :man_shrugging:

well friend, i did exactly what you asked, and this is what it outputs

[Angel@Xray ~]$ inxi -Fazy
bash: inxi: command not found

mean time i will try the kio pkgs solution to see if it works

inxi is included in Manjaro editions.
(its also just a common tool for providing system information)
While we are generally friendly people who like to help, as you are an Arch user, it would make more sense for you to seek assistance over at their forum.

looks like kio-extras, and kio-fuse came already installed with dolphin, so that would not be the problem

You probably don’t have inxi installed, because you’re running Arch. In Manjaro, it comes installed by default. It’s a system information script — written in Perl, I believe.

Either way, so the solution is… :point_down:

  1. Remove the Dolphin FlatPak; and…
  2. Run the following command in a terminal window… :point_down:
sudo pacman -S dolphin kio-extras kio-fuse libisofs

You may need to log out and log back in after that.

yep… but that’s exactly what i did before coming here, because there people is just not so prone to respond

don’t worry i’m not using the flatpack version, and i will never… that was just a test i did to figure out if it could work that way… but no i would never do something crazy like that.

and kio-extras and kio-fuse came already with the dolphin pkg, but you didn’t mention libisofs in your first response, so i will see if that’s already installed, and in case is not, i will see if that works

That’s because in Manjaro, it comes installed by default. It was not clear to me yet at that point whether you were running Manjaro or Arch. :man_shrugging:

libisofs wasn’t installed i did installed… nothing, i’m going to find the for inxi pkg… see if i can provide that info

Your question was answered on the Arch forum less than 4 hours after you asked.

1 Like

um… let’s see

thank you for that, i see that downgrading shared-mime-info to that specific version will bring back the functionality, so i will try, wish me luck

love u man… thank u… it was the latest version of that “shared-mime-info” thing, the cause of the problem, i did downgraded it’s working fine, thank you really, and thank you all of you who tried to help me with this problem, much love

:smiling_face_with_three_hearts: :heart_eyes: :upside_down_face: :person_gesturing_ok: :unicorn: :sun_with_face: