Dolphin file manager always opens on reboot

I’ve encountered an unusual problem. I am running KDE and whenever I reboot, the Dolphin file manager automatically opens to a directory from an external usb drive containing media files that I do not have actively connected. So it also shows a the error message that “the file or folder does not exist.” I can’t seem to stop this behaviour from recurring.

So even though the usb drive is not connected and Dolphin is not open when I reboot, it still opens to the same location. Dolphin is not activated in my autostart options, and from within the Dolphin preferences, I have it set to always open in my home directory.

One probable cause seems to be connected to when I was playing a media file from that usb, but vlc froze and would not quit while playing. When this happened, I rebooted. Dolphin is now opening to the directory where that media file would be (if the usb drive was connected, which again, it is not).

I’ve tried to search for some solutions on my own, but I can’t seem to find anything describing this kind of behaviour. So, I’m stumped! Thanks for any ideas or help!

EDIT: I’ve managed to stop it from always opening to the disconnected directory. Instead it is automatically opening just to my home directory, which is a slight improvement. However, I would like to prevent it from launching on every reboot altogether, and I still can’t seem to solve that. Again, it is not included in my “automatically started applications” in my “Autostart” options, so I really don’y know why it keeps opening on every reboot.

Maybe you use the option to Restore previous session ?
Try this settings:

1 Like

Well, that was simple enough! Thanks!

Starting with an empty session solved the problem. It is still strange to me that Dolphin would keep opening even when I had “restore previous session” though. I was actively exiting Dolphin every time and even tried killing the PID with kill -9. Yet everytime I rebooted, it still launched. But after trying your suggestion, the problem is gone. Even if I switch back to “restore previous session” Dolphin no longer opens!

Thanks for the help!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.