Dolphin doesn't find any file when searching "Frome here"

Topic pretty much says it all. I can’t seem to find any file when searching “From here” even if i type the exact filename of a file i’ll get “No matching element for search”. ANyone has a cloe what could be the reason?

1 Like

Do you have baloo running? This is required for all local search operations these days.

I’m not so sure.

(note that I have deleted any index that was ever created)

( though it is somewhat odd it is returning 2 entries of the exact same file :thinking: )

And of course there would be locate and its db if one uses that (I dont) … and things like find work without any db.

At least in my case Dolphin is using kfind
So … make sure that is installed.
Maybe also check your search settings in dolphin.
From dolphin search bar: More Search Tools > More > Configure

kfind seems to work though (i don’t know if this is my fault) i must search for the very exact name, otherwise it wont fnd anything neither. Using Double Commander works fine for searching all kind of files, also searching “my files” instead of “from here” seems to work as well.
Balooctl says it is running, though my Indexfile is pretty big i’d say (Over 1GB, but i also have a 4GB Drive connected)

It also seems like not every folder has this issue. For example the issue doesn’t seem to appear when searching from Home, though when i go to the Download Folder and start searching i wont find anything.

About the 2 Same files - i kinda had this issue as well before. But for me it were 4x the same file at the same location. After that it somewhat stopped working.

KFind in Dolphin never worked for me too, and I’m using Plasma 8 years… This is why I use only filter to find folders and files in Dolphin, and when I need to do a proper search, I use Krusader which uses an independent search, not relying on any databases.

This is beyond me, why search in Dolphin doesn’t work despite so intense development and bug fixing since few years, but it sucked 8 years ago, and it sucks right now. IMO this should be taken down from Dolphin, because it’s an embarrassment. Even if you know the file is there, it doesn’t find anything. Kursader on the other hand, always delivers.

Good to know, i might give that a shot if i can’t get it fixed.

Another discovery i made is when clicking More Search Tools > More > Configure from the search bar and using kfind… i see that search via database is greyed out, shouldn’t it be able to click? Since Baloo is running?

I don’t know. It isn’t grayed out for me, although my baloo is probably deactivated (can’t remember thou for sure, never needed it and probably deactivated when it started misbehaving).

OK, I found something out. The search requires you to put FULL NAME of the file. Otherwise, it doesn’t find anything. If you have a partial name, use * at the end or the beginning. Then it works. It is counterintuitive. The partial search should be the default and the need to use * shouldn’t be needed. It’s archaic.

So in the example above, when I was searching for “disney” alone, it wasn’t finding anything, but when I used “disney*” it finally did.

1 Like

Thank you that worked. That way files are found.
I start to think that i just mounted my drive to a “bad” spot /home/user/Storage. Maybe that somewhat causes my other issues.

i suppose that might be a product of it simply being a frontend for find.
Conversely … in dolphin … I do not need the correct/full filename.

Besides the double entry … the interesting thing is that it initially only has one … and duplicates them at the end.

Mine is as well … but I think you are correct it should be available in your case because baloo should be running.
Maybe check it?

balooctl status

Oh, yeah, baloo indexes certain things. You may have some selected and others not. Check baloo settings (“File Search” in app menu).

balooctl status
Prints out that Baloo Fileindexing is running but Indexingstatus is “inactive” and that there are still 20.00 files from 500.000 to be indexed lol. I guess i just messed stuff up by mounting NTFS under /home/ maybe that just causes confusion. I might just change the mount point. And see how it goes. But first i’ll wait and see what happend when indexing is finally complete.

Opening Filesearch through Systemsettings also takes pretty long to load up… and it seems that indexing of files is only done for like 2-3 Mintues after each reboot. However i can read there that 96% of files have been indexed. So maybe i’ll just need to wait and it will fix itself at some point.

Interesting. That one doesn’t work for me at all for some queries in some folders, while in others it does. It doesn’t make any sense and is confusing. Basically, when I look something in /home/user/ it works. When I try to find a file in, for example, /home/user/downloads, there are no results.

You are right, baloo is turned on. Hmm… Either I turned it on and forgot, or it turned itself. However, since it doesn’t cause problems, it can stay that way.

Okay i now just mounted the NTFS drives under /mnt/ instead and cleared the Index. And now Dolphin is able to find files in /home that it didn’t find before. So i guess it was somewhat related. In general i tend to use Double Commander anyways.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.