Dolphin browser & Taskbar frequently hangs, locks up, since Nibia 20.2

In a plain install of Manjaro KDE Nibia 20.2, every few minutes the following things happen (video time codes provided);

  • Taskbar lockup, can’t click Start button or any task buttons: 1:18
  • Dolphin browser lockup: 4:30
  • Force close Dolphin browser at 4:50
  • Frozen taskbar recovered by closing other Dolphin windows: 5:37

I recorded live for about 6 minutes and was able to reproduce all the above problems. Fingers crossed you guys know some random thing I can type into the terminal to fix all this… :smile:

[domarius@domarius-manjaro ~]$ inxi -Fazy 
  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=80d8c5eb-8161-42e6-91d4-c18148131aad rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: Z170-AR v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 3801 date: 03/14/2018 
  Device-1: hidpp_battery_0 model: Logitech M705 serial: <filter> charge: 100% 
  rechargeable: yes status: Discharging 
  Info: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP 
  arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: E2 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 64026 
  Speed: 4200 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 4201 2: 4200 
  3: 4200 4: 4200 5: 4200 6: 4200 7: 4201 8: 4200 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
  Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: Gigabyte 
  driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1f06 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nvidia 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3600x1200 s-dpi: 93 s-size: 983x321mm (38.7x12.6") 
  s-diag: 1034mm (40.7") 
  Monitor-1: HDMI-0 res: 1680x1050 hz: 60 dpi: 99 size: 430x270mm (16.9x10.6") 
  diag: 508mm (20") 
  Monitor-2: DP-3 res: 1920x1200 hz: 60 dpi: 94 size: 518x324mm (20.4x12.8") 
  diag: 611mm (24.1") 
  OpenGL: renderer: GeForce RTX 2060 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes 
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
  Device-2: NVIDIA TU106 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f9 
  Device-3: Audio-Technica AT2020USB+ type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-14:7 chip ID: 0909:001c 
  Device-4: Microsoft LifeChat LX-3000 Headset type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1:2 chip ID: 045e:070f 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel 
  port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8 
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Microsoft Xbox 360 Wireless Adapter type: USB driver: xpad 
  bus ID: 1-9:3 chip ID: 045e:0719 serial: <filter> 
  Local Storage: total: 8.64 TiB used: 7.32 TiB (84.7%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 2B2QEXE7 scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST31000528AS size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC38 scheme: MBR 
  ID-3: /dev/sdb vendor: Seagate model: ST2000DL003-9VT166 size: 1.82 TiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5900 rpm serial: <filter> rev: CC32 scheme: MBR 
  ID-4: /dev/sdc vendor: Seagate model: ST3000DM007-1WY10G size: 2.73 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5425 rpm serial: <filter> rev: 0001 scheme: GPT 
  ID-5: /dev/sdd type: USB vendor: Hitachi model: G ST size: 2.73 TiB 
  block size: physical: 4096 B logical: 4096 B serial: <filter> rev: 0000 
  scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: 50.00 GiB size: 48.97 GiB (97.93%) used: 20.14 GiB (41.1%) 
  fs: ext4 dev: /dev/nvme0n1p5 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: nvidia temp: 55 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 40% 
  Processes: 243 Uptime: 1h 16m Memory: 31.30 GiB used: 2.97 GiB (9.5%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 
  pacman: 1380 lib: 390 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08

Do you have installed any -git packages? if so then uninstall them and install the normal ones,there was a bug in the kde iso 20.2,its fixed already but if you have the old iso you need to resolve this manually.

Ok - when I reproduce the issue, I watch the System Monitor and nothing chews through CPU usage as in the screenshot of the thread you linked to. Web browser is always the highest at 10%. And I tried the fix of moving the mimeapps.list file from ~./config to ~/.local/share, rebooted, and was still able to reproduce the issue.

Actually the only -git installed is what came already installed, “user-manager-git”, which actually is related to the thread you linked to.

I downloaded the ISO on 6th December, and according to that thread, the fix was applied 8th December. So boy was I unlucky. Does the current ISO for Manjaro KDE currently live on the website have the fix?

According to this,yes its fixed,it was fixed on 7th December.

Oh whew. Thank you. I’ll look out for the scripts then! I just spent the whole day building my system up with all my software and shortcuts etc… if that script saves me from re-doing all that, that would be greeeaatt…

Alright!,but just in case,do you uninstall the user-manager-git? according to this you can uninstall it

Bad news. Just uninstalled it, rebooted, and reproduced the issue immediately…
Really hope I don’t have to re-set up my system.

Where do I look out for these scripts?

The script is now available in this thread: Manjaro 20.2 Nibia got released. It is in the first post.

Bad news, I ran the script, it almost completed sucessfully, but for some reason, attica-git didn’t get removed the first time around, which left attica and attica-git in conflict. I ran the same lines that the script does, to remove attica-git and install attica, which completed sucessfully that time. Rebooted, confirmed attica was installed and attica-git wasn’t, and I was still able to reproduce the above problems in minutes.

It’s looking more and more like I’ll have to re-install and set up everything… again…

Try this: [KDE] Dolphin is very laggy and stops responding sometimes

Thanks. I actually tried that before this. It made no difference, and also Dolphin (or any other program) isn’t using excessive CPU usage, the highest is the web browser at only a few percent.