Doesn't proceed after login in

Hi everyone! I was mindlessly trying to install dwm just to try it out and ended up modifing the .xinitrc file with adding exec dwm at the bottom and then running sudo startx (don’t know what that does) and then I rebooted my laptop.

When it returned back I still couldn’t choose dwm to be my window manager but a more important problem is that I am stuck in the log in screen.

I write my password and click login and it doesn’t proceed to the window manager but it returns me back to the login screen to write my password again.

Any solution?

What is the DE you are using?
(I don’t even have that file .xinitrc in my HOME)

since you have no access to a terminal
go to a TTY
log in and list the contents of your HOME directory, checking for files not owned by you

ls -al | grep root

depending on whether something is found, either remove it or inspect it first and change the ownership to you
sudo is needed to do that

brings you back to your normal display

Where you in a TTY when you did that,
or did you do that from within your session?
It couldn’t have worked either way because the Display Manager was probably still running.
But it could have created one or more files now owned by root in your HOME - which can cause problems.
Hence the check for that at the beginning …

If you need the unmodified .xinitrc
cp /etc/skel/.xinitrc ~/

While you are at it - or before you even start the procedure:
consider installing a terminal file manager - it’ll help you navigate the task
sudo pacman -S mc

I solved this by reinstalling the OS again.

mkay, the nuclear option … :wink:
you didn’t solve it, though - just got rid of it
… whatever works

1 Like