Does not work OBS Studio

Hello everyone.

I need to record a screen with audio in real-time .
At first I used RecordMyDesktop. It’s simple, it works, but it’s inconvenient to use because it takes a very long time to write the output file.

Then I tried the complicated OBS Studio.
Version 29.0.2-1 was installed successfully, but an error occurs at startup:

$ obs
obs: error while loading shared libraries: cannot open shared object file: No such file or directory

How can I fix this error?

Or perhaps there are other, more successful and simpler applications?

sudo pacman -Fy

and Install the package where the library depend on. Otherwise you need none free mesa.
Or install it via flatpak.

This is part of ffmpeg. But at least on stable branch on desktop there is no such version (59).

read whogotit; sudo pacman -Fyx $whogotit   
[sudo] password for teo: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 multilib is up to date
extra/ffmpeg 2:6.1.1-6 [installed]
extra/ffmpeg4.4 4.4.4-4 [installed]

On desktop (x64) i use VokoscreenNG and it works well.

1 Like

Simple Screen Recorder might be an option. It is available via the AUR.

How did you install that? Because the version in the official (stable) repository is 30.0.2-4.

He is on arm, the version there is 29. BTW i just checked, it seems there i vokoscreen for arm.

1 Like

How did you install that? Because the version in the official (stable) repository is 30.0.2-4.

Sorry, perhaps my Manjaro doesn’t want to be updated?

When I try to update Manjaro, it says it has already been updated.
He has been talking about this for a long time, more than one month, and it is suspicious :astonished:

Ignore my post, @Teo says above that apparently version 30 isn’t available on ARM for some reason? Which is probably the cause of the problem.

Thank you, I managed to install VokoscreenNG of the stable official branch and it worked! :beer: :beer:

And I deleted the nasty unfinished OBS Studio :face_with_symbols_over_mouth:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.