Does kio-gdrive in dolphin need kwallet to access Google Drive

I am trying to access Google Drive using KDE dolphin and went as far as creating a folder named google1 that did not load.

When I tried to delete the folder, I could not, and I had to kill the process eventually.

Is activating kwallet a prerequisite for accessing Google Drive via dolphin using kio-gdrive?

In any case, how may I delete the dud folder google1?


Not really. I have kwallet running, but there’s nothing saved in there that I know of.

Where did you create this folder? I myself set it up under the network section of the Places, but then I made a symbolic link to it in my home directory.

I created the folder in dolphin, under Remote -> Network -> Google Drive.

No symbolic link.

Indeed, I do not know where the protocol gdrive:/google points to because then I can at least delete the folder.

I am able to delete it on my system ─ not that I’ve tried, but the option is available ─ but maybe you are in the folder when you’re trying to delete it. Have you tried closing all tabs that lead to what is in the folder?

I am in the tab containing google1 as a folder in dolphin, but have not traversed the folder itself., i.e., I am able to view the folder as one entity and can press delete with the bin icon (not move to trash). The deletion notification appears but never ends. The folder is also stubbornly persistent on subsequent reloads of dolphin. I have had to kill dolphin as well to use it again.

What about removing it by right-clicking on it under the Network section in the left-hand pane?

It does not appear on the left hand pane, and I cannot drag and drop it, nor can I add it to the left pane. So, until I figure that out, I am stuck, I am afraid.

See whether the Network section is among the “hidden places”. If it is, then you can make it visible again from the menu.


I am afraid that that is not the issue. I simply need to know where I should modify a text file in order to make the google1 go away, since deletion does not work.

To be more precise, short of uninstalling kio-gdrive, is there any location on my system where I can delete the link/symlink/folder called google1 so that it does not appear in dolphin anymore and therefore cannot cause endless loop processes?

It might be under ~/.cache/kio_http, but I don’t know as those files are not human-readable. I can’t find any other possible location. :man_shrugging:

1 Like

I found it!

It can be removed so:

System Settings -> Personalization -> Online Accounts

and one may simply remove it from the panel that appears.

Thank you @Aragorn for your kind suggestions.

1 Like