Does GPS work? Can you help me?

I wanted my PinePhone to be more “daily driver ready”, so instead of beautifully looking plasma-mobile I installed manjaro phosh.

I was impressed with the stability and with working cellular data connection (because plasma “stable” behaves like dev and the “real dev” even worse :laughing:)

I wanted to try maps, so I searched for them and tried to install OffRoad (de facto OsmAnd) - didn’t work at all (didn’t even launch), so I tried to install things like marble. (if I didn’t mention it already, the default maps kindda work - only with internet connection).

I also wanted to try GPS, because I want to use it in the future - but I’m not an expert about GPS things and don’t know exactly how to make it work.

I know that GPS (location services) are below some “security settings” and I can enable it there.

The thing is, that the preinstalled maps (I believe these are gnome maps) just show me where I am and if I move, they don’t display it.
With marble I can find more location options like “qt positioning” - which somehow tells me my position, but there is another option called “gpsd”, that I didn’t get to work (and I think It’s the real GPS positioning).

Is there an app, that could give me informations about my GPS sensor?
Is there an easy way for me to make it work?


Soon there will be an announcement about beta10, but i don’t think much changed in that regard. Also GPS is part of the modem, so if you toggle the modem privacy switch you’ll also disconnect the GPS.

This might help

So it isn’t my problem? :laughing:

Yeah, I know that. I actually do not use these switches that much and right now they are all on

Thanks, deffinitely gonna read it :slight_smile:

Btw, is there a working app for offline maps?

Just did a test and GPS seems to work fine with latest image … and using Maps, quite acurate actually. Will test more once i’m on the move.
Not sure about an offline app … have to check.

Thanks for your patience with me,
I use the last image and today I tried default maps (gnome maps) with location services on.
It found me, but when I was moving, It just didn’t notice…

Btw, I really appreciate the option, that I can set my screen to “100%” instead of “200%”
It is useful, when I try to open desktop apps - on plasma mobile I see half of them, phosh has this solution which works well for me :slight_smile:

So I tried it
(I was in a car)

It just showed me, where I am, and after some time it changed. And again and again.
It just doesn’t show you all the time, where you are - it looks like it updates your position time by time

Sometimes It actually showed me, that I was somewhere, where I clearly wasn’t, or where I was 5 mins ago, even though I was a few kilometers from that place already

1 Like

I also tried out GPS on Phosh Beta 10 -

Seems like GPS was workign with Gnome Maps. Like @Muskwa was saying, is exactly how i feel about the current status of it - would be nice to have a normal car view navigation system working.

Next couple of days, I plan on testing couple GPS program within Anbox and seeing if those work.

If I’m right, Offroad is something like ported OsmAnd - but I somehow couldn’t run it on my PinePhone