Does Fall Apart effect work in your Kde Plasma?

It doesn’t works in my system since a recent update. (x11)

I put in a bug report on the KDE bug report site, but have to wonder if this is a Manjaro issue. I say this cause I have ArcoLinuxB on a secondary SSD with Plasma 5.24.3 and Fallapart still behaves as it should, where as in both my Manjaro and my roomates Manjaro it doesn’t.

3 Likes

As it is the window manager which makes the effects and kwin creates the mentioned effect on LXQT/kwin - it makes me think theming issues.

My window manager is kwin 5.24.3

$ inxi -Sxxx
System:
  Host: ts Kernel: 5.15.27-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: LXQt 1.0.0 tk: Qt 5.15.3 info: plank, lxqt-panel wm: kwin_x11
    vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux

Doesn’t take away from the fact that something in the system itself can be interfering with it. As for theming issue I don’t think so since everything right down the line for theme is the same in both Manjaro and Arco.

If it works in other distro, then it’s connected with Manjaro.
I was planned check that in virtual box, but when I’m going to install that effect, I can’t find it :sweat_smile:

We know that

  • LXQt/kwin_11 on Manjaro - effect is functional
  • System unstable branch
  • kernel 5.15.27
  • AMD Radeon WX7100

I am no Plasma nor KDE user - so I clearly know no nothing - my guess however is something Plasma related - perhaps conflicting settings - or the global theme?

I have played with some kwin tiling scripts and a script can completely alter the window manager’s function - so it is entirely possible the default Manjaro theming somehow makes that effect non-functional - but this is pure guess work on my side.


So I took my test system and installed the minimal KDE Plasma from the website.

With the default Manjaro theme - the effect you seem to like works - kind’a - the login and logout fall apart - all other windows fade.

I do think that @ishaanbhimwal’s reference may be more accurate than my quick test - just checking the link provided and I think your answer lies within the change made - which would also explain why the login and logout is animated as fall apart.

There entire the lack of fall apart effect is most likely caused by the plasma integration as my system - which is not using Plasma shell but LXQt - also using kwin can do it just fine.

1 Like

fallapart was recently updated to avoid animating windows while there’s a fullscreen effect. Try disabling that and see if it works.

1 Like

Disabled all other effects, still doesn’t works.

Sometimes when something wonky happens I like to try on another distro, so one of the ones I use is KDE Neon testing in virtualbox. Anyway, I found several effects are no longer present. There is no Fall Apart, Magic Lamp, Wobbly Windows and so on. This may mean we’ll soon see these effects removed with future updates (unless the manjaro devs do decide to somehow keep them), or might mean they’re temporarily missing while nobody maintains them.

Keep in mind: This could very well be a (virtualbox) problem with failed 3d acceleration…

1 Like

That would be great but I have no full screen effects in either OS. Both Manjaro and Arco are setup exactly the same way.

This ios a vitrualbox issue. Not the way to test effects cause most of them you will not get. Betting if I install Neon or Kubuntu on bare metal all the effects will be there.

Doesn’t work for me either. :thinking:


System information:

Operating System: Manjaro Linux
KDE Plasma Version: 5.24.2
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.16.11-2-MANJARO (64-bit)
Graphics Platform: X11
Graphics Processor: NVIDIA GeForce GTX 1650/PCIe/SSE2


Perhaps fixed in KDE Frameworks 5.24.3?


UPDATE: Found a solution by mistake!

Settings → Workspace Behavior → Desktop Effects → Window Open/Close Animation

Set this to “Fade”.

Set this to something else, and then click Apply.

Viola! :sunglasses:


UPDATE 2: It appears that in order to get “Fall Apart” to work, you simply need to change “Window Open/Close Animation” to something else, and then click Apply. This appears to “reset” a faulty setting that “blocks” the “Fall Apart” effect.

6 Likes

You may be on to something. I can’t say cause I had a bad bios update take down both OS’s and only now have Arco reinstalled. I set all my Desktop Effects and apply all at once. This behavior is something that started some time after the 5.24.0 Plasma update, so yes it’s possible that your workaround could do the trick since I did the Desktop Effects well before getting the 5.24.0 update.

Sorry to take so long to respond. Yes you are correct and I am wrong. All those effects are available once I checked the 3d acceleration box in virtualbox. To veer off on a bit of a tangent, this is why I think it’s a bad idea for software to just hide options, I think a better way of “hiding” them is by making them greyed out/unselectable or hidden behind a tab with a message “currently unavailable on your hardware” or something along that lines. Anyway thanks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.