Does anybody know a way to install GNURadio that works?

Here’s my story. Please bear with me, as it’s somewhat relevant.

I bought myself a hackrf porta-pack for Christmas. It showed up some time in January, and I had a happy month or month and a half messing with it. I installed gnuradio, a spectrum analyzer, and various other software, and everything worked fine.

Some time in March, we had an update that broke gnuradio. I don’t remember what now, But I’ve been messing with this on and off in my spare time since early/mid-march, and I can’t find a version of gnu-radio that will work. (Side note: There are two versions of gnuradio-companion, both in Community repo, both v3.8.2.0-3. But leaving that alone for now…)

I tried the standard version in the community repo, and it fails to build with an error about dependencies (about 50 different python things with weird names like noodle and cheetah and such).
Then there’s a maintenance version in the repo, which fails with the same error.

So I went to the gnuradio official page and followed their instructions for building from git. This version fails at launch with some error or another. Something about cmake.

Turns out, the master branch is broken, has been for some time, and you’re supposed to build from the maintenance branch. This works and installs the software. But it fails to run any of my flowchart blocks because it says it can’t find libgnuradio3.8.2.

Does anybody here use gnuradio? Does anyone know a way to install it that both A) installs and B) is usable when it’s done installing?

Not trying to sound like a jerk or whatever, but this is pretty maddening running in circles, install, uninstall, dependency hunt, clone this, download that, compile the other… Doubly so since I did have it working at one point, and I somehow managed to do it with little to no effort.


Never heard of that tool.

But why don’t you use GNU Radio Companion provided by Manjaro in the repos?

That’s the gui front end for gnuradio. Companion won’t work without gnuradio. Gnuradio won’t build from the repo.

And did you try gnuradio-git from the AUR in Pamac?

The community repo version is already built, it sounds like you’re attempting to build it from the AUR.

Install it from Add/Remove Software or with:

pamac install gnuradio-companion


sudo pacman -Syu gnuradio-companion

Pardon my imprecise phrasing. I’ve tried all the versions available - Community Repo, AUR, and git.

Trying to use pamac/pacman, the program fails to launch every time.
That seems to be a recurring problem, as even if I compile gnuradio myself, and I try to run a flowchart, I get an error that it can not find that lib.

(Picture attached. Just did a fresh install for the reply.)Screenshot from 2021-05-02 17-39-49

I can’t reproduce that with the community repo version. :man_shrugging:

I installed the GNU Radio Companion and it seems to work but I’m not sure what doesn’t work for you.
//EDIT: will try to find sample files to open.

This poster had a similar problem. I didn’t want to resurrect a dead thread, though. That error output he lists is the same as I get if A) I can get the program installed and B) If I can run the program.

Is this maybe because I’ve done about a dozen installs now? I’ve tried clearing out orphans and stuff, but if there are config/log files left over from an older build, maybe it’s pointing to the wrong location? (Just thinking out loud here.)

gnuradio 3.8.2-3 is the last version that works with gnuradio-osmosdr. Unfortunately, it is no longer being developed and therefore does not work with version

Why are you trying the build yourself - I don’t understand.

You need the following installations.

Well, information is actually kind of sparse unless you know where to look and what to look for. I searched gnuradio, and ended up at their github, which has handy-dandy instructions for installing. It’s only after installing and googling all the errors that arise that I even find out that Master branch is broken, has been for like 2-3 yrs, and you’re supposed to build from a maintenance branch.
And the only reason I went down the build/compile road is because the working install that I had broke after an update.
So yeah, just an unfortunate set of circumstances, really.
Also unfortunate is that after installing the packages you recommend, I get the same error I outlined above (capped again here for the record).Screenshot from 2021-05-03 16-19-38
I tried running sudo ldconfig -v after that (seemed the appropriate thing to do), but it didn’t help.