Docking Station will not display via DisplayPort

Newbie here! I recently installed Manjaro on my Dell XPS 15. I have a docking station (Dell WD19TB) to use two monitors, which connect via DisplayPort. Currently, the dock allows PCI devices (i.e., mouse, keyboard, webcam) to function but the monitors do not display.

The docking station will allow the laptop to display via HDMI. In addition, both monitors will display via DisplayPort when I boot from the installation disk. I believe that this may be an issue with my NVIDIA graphics card and corresponding drivers, but I can’t determine what is going on. Any assistance is appreciated!

System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=c49f958f-fdf9-4c56-bfaa-1d8106924c8c rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: XPS 15 9560 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 05FFDN v: A00 serial: <filter> UEFI: Dell v: 1.19.2 
  date: 05/22/2020 
Battery:
  ID-1: BAT0 charge: 92.9 Wh condition: 92.9/97.0 Wh (96%) volts: 12.6/11.4 
  model: LGC-LGC8.33 DELL 5XJ287A type: Li-ion serial: <filter> status: Full 
CPU:
  Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: D6 
  L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 44817 
  Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:591b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell driver: N/A 
  alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 chip ID: 10de:1c8d 
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-12:5 chip ID: 0c45:6713 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: modesetting 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 dpi: 141 size: 346x194mm (13.6x7.6") 
  diag: 397mm (15.6") 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.1.8 
  direct render: Yes 
Audio:
  Device-1: Intel CM238 HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 chip ID: 8086:a171 
  Device-2: Realtek type: USB driver: snd-usb-audio bus ID: 3-2.3.4:7 
  chip ID: 0bda:402e serial: <filter> 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Bigfoot Networks driver: ath10k_pci v: kernel port: e000 
  bus ID: 02:00.0 chip ID: 168c:003e 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:2 
  chip ID: 0cf3:e301 
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
  bus ID: 4-2.4:4 chip ID: 0bda:8153 serial: <filter> 
  IF: enp11s0u2u4 state: down mac: <filter> 
Drives:
  Local Storage: total: 953.87 GiB used: 16.84 GiB (1.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50ZNV1T02 NVMe 1024GB 
  size: 953.87 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: AADA4106 scheme: GPT 
Partition:
  ID-1: / raw size: 596.76 GiB size: 586.39 GiB (98.26%) 
  used: 16.80 GiB (2.9%) fs: ext4 dev: /dev/nvme0n1p7 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 60.5 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2517 fan-2: 2504 
Info:
  Processes: 234 Uptime: 1m Memory: 31.22 GiB used: 1.27 GiB (4.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1201 lib: 321 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

:+1: Welcome to Manjaro! :+1:

  • Is this a fairly new install? (how long have you been running like this)
  • Did you install Manjaro while your docking station and monitors were connected?

(You see where I’m going with this, right?)

:grin:

Thank you! Glad to be a part of this community :slight_smile:

I installed Manjaro last week. I did not install with the devices attached.

I don’t think I follow – still a newbie, so I’d appreciate if you spelled it out.

This is where I was going:

  • back up your documents (not the settings)
  • reinstall with everything attached.
  • restore your documents

:man_shrugging:

I will do that, but can you help me understand how the installation is changed and why I couldn’t configure my installation now to produce the same result?

I don’t have a docking station, but am hopeful that the automatic install will detect all your monitors when they’re connected during the installation phase…

I see – thank you for your help! I’ll be sure to update with how the re-install goes.

As you might guess, this worked! I guess the lesson learned is to trust the automatic install :sweat_smile:

Thank you @Fabby for your help! I really appreciate it.

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

:innocent:
P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like