Docker container won't run (And yes I have executed sudo dockerd)

In the begining docker was working fine then im not sure what happend but docker randomly stopped being able to create new docker containers so what I did was uninstall docker (pacman) and removed its traces, then I re-installed it again and it still didn’t work so I tried the snap version and it didnt work so I tried the docker-bin from the aur and it didnt work, ill explain other things in the below

So I have this problem where when I use
docker run ubuntu
It will not run
And yes I already have the images downloaded

docker start optimistic_goldberg
it will not say started but instead say
in console and when I do
docker ps -a
It says Exited (1 second ago)

And yes I have tried other images debian, manjaro, arch, node images and they all don’t work.

And this is the logs from the sudo dockerd command

This is logs with the sudo dockerd -D command but it excceded the pastebin limit so ill use another site to paste the log,

Things I tried to fix this:
Switching Kernels
Using other package managers like snap/aur
Removing docker traces

Things that may be usefull:

INFO[2021-03-13T16:40:02.987224202+07:00] shim disconnected id=d623a2901ed70393a0fb8acfb4a1539286607a8ecb7d66725f1359683b97f230

INFO[2021-03-13T16:40:02.987333638+07:00] ignoring event container=d623a2901ed70393a0fb8acfb4a1539286607a8ecb7d66725f1359683b97f230 module=libcontainerd namespace=moby topic=/tasks/delete type="*events.TaskDelete"

ERRO[2021-03-13T16:40:02.987389290+07:00] copy shim log error=“read /proc/self/fd/14: file already closed” DEBU[2021-03-13T16:40:02.988408756+07:00] Revoking external connectivity on endpoint optimistic_goldberg (a7d415a863623be63ec730cbb9e74113efab02a63b46aa881a2ed7384edd584a) DEBU[2021-03-13T16:40:02.989242169+07:00] DeleteConntrackEntries purged ipv4:0, ipv6:0
DEBU[2021-03-13T16:40:03.247329914+07:00] Releasing addresses for endpoint optimistic_goldberg’s interface on network bridge
DEBU[2021-03-13T16:40:03.247386184+07:00] ReleaseAddress(LocalDefault/,
DEBU[2021-03-13T16:40:03.247426100+07:00] Released address PoolID:LocalDefault/, Address: Sequence:App: ipam/default/data, ID: LocalDefault/, DBIndex: 0x0, Bits: 65536, Unselected: 65532, Sequence: (0xe0000000, 1)->(0x0, 2046)->(0x1, 1)->end Curr:3

DEBU[2021-03-13T16:40:04.110877995+07:00] event published ns=moby topic=/containers/delete DEBU[2021-03-13T16:40:14.030373175+07:00] garbage collected d=26.004652ms

If you need me too provide any other infromation just infrom me on the comments Thank You for reading!

Executing dockerd is not a good way to start the daemon. Do not do that!

Use systemd to start the docker daemon.

systemctl start docker

and check the status

systemctl status docker 

This is not the way you can start a container that does by default nothing. Docker will start the container and the it immediately exits.

You might want to read up on how docker works. If you simply want to start the container and get an interactiv shell you can use

docker run -it ubuntu

But keep in mind the moment you exit the bash shell the container stops!

Oh it worked but didn’t solve the containers not executing problem

Well did you tried

docker run -it ubuntu

As the ps output shows the ubuntu contain ran in the past. But it does nothing by default. Because of that it stops. A container is not a VM!

Omg thank you so much I didn’t know you need to but -it

Keep in mind, the moment you exit the shell, the container stops.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.