Do we need PSI to run Waydroid?

I’m still struggling to get Waydroid working on my Pinebook Pro.
I found this thread and some people report that PSI should be active.

So I tried checking for PSI.
$ zcat /proc/config.gz| grep ‘PSI’
CONFIG_PSI is not set

$ cat /proc/pressure/cpu
cat: /proc/pressure/cpu: No such file or directory

I also tried adding “psi=1” in extlinux.conf, but that doesn’t seem to make any difference.

LABEL Manjaro ARM
KERNEL /Image
FDT /dtbs/rockchip/rk3399-pinebook-pro.dtb
APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS2,1500000 root=LABEL=ROOT_MNJRO rw rootwait binder.devices=“anbox-binder,anbox-hwbinder,anbox-vndbinder,binder,hwbinder,vndbinder” video=eDP-1:1920x1080@60 video=HDMI-A-1:1920x1080@60 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash psi=1

So in short, do I need PSI for Waydroid and how do I activate it?

5.16.4-1-MANJARO-ARM has CONFIG_PSI=y

Are you on stable?
I have kernel 5.16.2-4.
$ uname -a
Linux PinebookPro 5.16.2-4-MANJARO-ARM #1 SMP PREEMPT Sun Jan 23 23:38:07 UTC 2022 aarch64 GNU/Linux

What do you get with this command?
$ cat /proc/pressure/cpu

The kernels with PSI are not in stable branch yet. They are in Unstable and Testing right now.

Thanks for the update.
So that means that other people have Waydroid running without PSI?
Assuming they use the standard kernel.

Just sounds like Waydroid added this requirement recently.

Got the new kernel and PSI is activated and Waydroid is working!
It could be something else, but at least we know Waydroid is working on the Pinebook Pro with Manjaro.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.