DNS Refusal only on my Manjaro Linux

I been working hard to pass a wifi channel on a dumb ap, using vlan, to wireguard on my main router to get a vpn working through a wifi channel. It works finally on my phone and on my windows dual boot with no dns leak issues. However on manjaro linux if I do dig google @‘vlanIp’ it refuses dns. I also cant get dns on my browser, pinging works fine but pinging google refuses nameserver. I tried connecting an ethernet cable to my computer with the same vlan, and its the same issue, works on the other vlans that pass to wan fine.

On windows and my phone the dns doesnt refuse. I tried to go to /etc/systemd/resolved.conf in manjaro and add DNSSEC=no, but that didnt help, and dig internetsociety works on termux on my phone so a dnssec refusal doesnt seem like the issue. What reason could my Manjaro linux be blocking my dns connection that my phone and windows would not? How can I troubleshoot further?

Using systemd-resolved has some prerequisites - namely

  • sync systemd-resolvconf package
  • enable and start systemd-resolved service
  • backup your existing /etc/resolv.conf
  • create a symlink for /run/systemd/resolve/stub-resolv.conf*
  • remove openresolv
sudo pacman -Syu systemd-resolvconf
sudo systemctl enable --now systemd-resolved
sudo mv /etc/resolv.conf /etc/resolv.conf.bak
sudo ln /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf
sudo pacman -Rns openresolv

I was just trying to troubleshoot, I have no idea what that all really does and I dont want to mess with it just to troubleshoot something, if it may be a dead end anyhow. I tried a manjaro boot disk to troubleshoot further and it works with that? So it seems like something either with the security features of a fully installed manjaro or my manjaro instance in particular.

There is no special security features - it is a matter of configuration.