Dns problem in manjaro gnome

In my manjaro gnome system I can ping and ip address of any website but not the domain names and I got the error Temporary failure in name resolution.
I checked the file /etc/resolv.conf and it’s empty.
I tried updating the dns in the gui settings and also with nmcli con mod 'connection name' ipv4.dns But after re-activating the connection and also multiple reboots nothings is changed and the resolv.conf file is still empty.
Also tried setting the nameserver in the /etc/resolvconf/resolv.conf.d/base file, but still no luck.
I cannot update my system or install any other softwares with pacman due to this problem.
Can somebody help me solve this?

can you provide

inxi -Fza

Your issue is not a basic issue with Manjaro - but a local network configuration.

Such issue is is next to impossible to troubleshoot remotely.

The first step is to restart your router and thus the dns service.

Undo/Revert any customization you may have made in networkmanager.

/etc/resolv.conf is controlled by the resolvconf program and written by NetworkManager.

You can control resolvconf using the /etc/resolvconf.conf file to set a specific nameserver - and this is great for troubleshooting. It is highly recommended to locate the actual issue interfering with setting a nameserver



run resolvconf to update the resolv.conf

sudo resolvconf -u

then reset your network (from your inxi the eno1 is your nic)

sudo ip link set eno1 down
sudo ip link set eno1 up


In some situations it may help to remove openresolv package and enable systemd-resolved.service.

sudo pacman -R openresolv
sudo systemctl enable --now systemd-resolved.service
  Kernel: 5.15.81-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=7b4eedc1-e7c5-4b37-8b33-941faedb2220 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 43.1 tk: GTK v: 3.24.35 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Hewlett-Packard product: HP EliteDesk 800 G1 SFF
    v: N/A serial: <superuser required> Chassis: type: 4
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 1998 serial: <superuser required>
    BIOS: Hewlett-Packard v: L01 v02.53 date: 10/20/2014
  Info: model: Intel Core i5-4590 bits: 64 type: MCP arch: Haswell gen: core 4
    level: v3 note: check built: 2013-15 process: Intel 22nm family: 6
    model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 2631 high: 3293 min/max: 800/3700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2561 2: 1377 3: 3293
    4: 3293 bogomips: 26350
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: Hewlett-Packard EliteDesk 800 G1 driver: i915 v: kernel
    arch: Gen-5.75 process: Intel 45nm built: 2010 ports: active: VGA-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:0412
    class-ID: 0300
  Display: x11 server: X.org v: with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: crocus gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-size: <missing: xdpyinfo>
  Monitor-1: VGA-1 model: LG (GoldStar) HD PLUS built: 2016 res: 1600x900
    hz: 60 dpi: 92 gamma: 1.2 size: 440x250mm (17.32x9.84") diag: 506mm (19.9")
    ratio: 16:9 modes: max: 1600x900 min: 720x400
  API: OpenGL v: 4.6 Mesa 22.2.4 renderer: Mesa Intel HD Graphics 4600 (HSW
    GT2) direct render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: Hewlett-Packard EliteDesk 800 G1 driver: snd_hda_intel v: kernel
    bus-ID: 00:03.0 chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    vendor: Hewlett-Packard EliteDesk 800 G1 driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:8c20 class-ID: 0403
  Sound API: ALSA v: k5.15.81-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.61 running: yes
  Device-1: Intel Ethernet I217-LM vendor: Hewlett-Packard EliteDesk 800 G1
    driver: e1000e v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:153a
    class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 74.53 GiB used: 20.64 GiB (27.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Maxtor model: STM380811AS
    size: 74.53 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    type: N/A serial: <filter> rev: E scheme: MBR
  ID-1: / raw-size: 74.53 GiB size: 72.81 GiB (97.69%) used: 20.64 GiB (28.4%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 36.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 206 Uptime: 37m wakeups: 0 Memory: 7.67 GiB
  used: 1.26 GiB (16.4%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1331
  pm: pacman pkgs: 1327 libs: 321 tools: gnome-software,pamac,yay pm: flatpak
  pkgs: 4 Shell: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.24

Thank you! I didn’t remove openresolv and yet enabling systemd-resolved service solved the problem.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.