DNS leaks with SurfShark VPN

I run Manjaro Cinnamon edition on a laptop (thinkpad x230t) I installed the SurfShark VPN app for linux some time ago (GUI app 2.2.0). I’m currently traveling overseas and I use the VPN to connect to streaming services back in my country (Australia), But I can not watch anything as the streaming services somehow know I’m out of the country?! I did some digging and found that my computer leaks DNS? When I run a DNS test while the VPN is on set to my home country in the test result I can see both the VPN DNS and the WiFi DNS from the hotel I’m staying in? I should only see the VPN DNS.
I like to know what I can do (if anything) to avoid those DNS leaks? Is it an issue with the VPN provider (the protocol used is: WireGuard)? The WiFi provider/router setup? or my OS set-up or some settings to change? Thanks

Typically, this is the fault of your VPN provider which doesn’t setup routing DNS through the tunnel.

If they provide their own DNS servers, you should check how to set this up. Otherwise, the streaming service might know your VPN providers endpoint and doesn’t support this setup.

It is difficult to say why you are running into dns leak.

Usually the vpn provider rewrites the /etc/resolv.conf to contain the nameserver.

  • Make sure you have not created a split tunnel.
  • Make sure you are using systemd-resolved instead of openresolv.

To change your system to systemd-resolved

sudo pacman -Syu systemd-resolvconf
sudo systemctl enable --now systemd-resolved
sudo mv /etc/resolv.conf /etc/resolv.conf.bak
sudo ln -s /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf

I’m think I have systemd-resolved running on my system. in etc/ there is resolv.conf, and resolvconf.conf
Anyway the issue was probably with the WiFi/ISP provider as I have now moved to another location within the same country (Italy) and in this location I do not have a DNS leaking issue (different WiFi/ISP provider and/or router setup). As a guest in an Airbnb apartment, I have no access to the router settings, so if I encounter this issue again, if there is anything I can do to my laptop settings to stop this DNS leaks, I would like to know. Thanks

I have solved the problem for surfshark users here: