DLSS & Screen Resolution Gaming Issues


I am new to gaming on Linux. I recently bought a Legion Laptop with an Intel i7-11800H and Nvidia RTX 3070 and I am have a couple issues gaming. Currently I am gaming using Epic Games and Lutris. The game I am having issues with is Control. I can get it to run but I can’t seem to get DLSS/Ray Tracing enabled, nor can I play it at the max resolution of my laptop screen.

Below are the issues more in depth.

  1. Can’t game at max screen resolution of 2560X1600 as no options show up. The max I can set it to is 1920x1080. This seems to be a scaling issue as I am using Manjaro KDE and have scaling set to 162.5%. If I turn off scaling I can use the max resolution in the game, but then scaling is off, and switching back and forth is pretty inconvenient.

  2. Can’t seem to get DLSS or Ray Tracing activated. Settings says I need an RTX card which I have in the form of a RTX 3070. I tried to launch games via adding the game into Steam and enabling Proton Experimental and the game wasn’t even able to launch. I tried Heroic game launcher and lot off other things from Youtube, forums, and stuff I can’t remember. Finally I broke my installation by uninstalling the hybrid intel/nvidia driver and trying to enable the nvidia driver which then I was forced to reinstall Manjaro. Thus, I have a fresh install of Manjaro and rather not break the installation again.

Thus, any help would be appreciated. The resolution issue I can maybe get by with, but I would really like to solve the DLSS & Ray tracing issue.

Thank you.

Use GE-Proton or Proton Experimental from Steam. No idea about Epic. Other than that, see the ProtonDB entry for launch flags to use.

Thanks but using GE-Proton doesn’t seem to work either.

If enable compatibility through Steam via any Proton including experimental and GE-Proton the game fails to load with and without launch flags.

I tried the following launch options

PROTON_ENABLE_NVAPI=1 VKD3D_CONFIG=dxr %command% -dx12

gamemoderun VKD3D_CONFIG=dxr11 PROTON_CONFIG=dxr11 VKD3D_FEATURE_LEVEL=12_1 PROTON_HIDE_NVIDIA_GPU=0 PROTON_ENABLE_NVAPI=1 %command% -skipStartScreen -dx12

I am not sure if it is because the game is originally from the Epic games store or not. The game launches perfectly fine with compatibility OFF, but then still no DLSS or Ray tracing is available. It only fails to launch when compatibility is ON.

Thank you.

For non-Steam games via Lutris, use Wine-GE-Proton.

Sweet Thanks. That for the most part worked. I am nitpicking at this point , but Ray Tracing is still not available/working? Any options?

For others, here is what I did to get DLSS to work.

I downloaded the latest Wine GE Proton and extracted to the wine folder as below

  1. Extract wine-name-branch-x86_64.tar.gz to /home/USERNAME/.local/share/lutris/runners/wine/

Then reload/boot Lutris. You can’t launch the game through Epic Games Store or it will not work, atleast for me.

Thus, I went to the Lutris menu and clicked on Add games and selected 2019 Control and installed the Wine EGS install. I finished the install. You should have a Control Icon under your Games section in Lutris. I went into the configuration and Game Options and found my Control_DX12.exe and set my executable path towards it’s location. Then I went Runner Options and set Wine Version to the latest Lutris-GE-Proton.

Again Thanks.

Finally launch the game and the ability to enable DLSS is there.

Finally got Ray Tracing to work with DLSS for Control with Lutris and Epic Games.

To do that you have to configure the game through Lutris and add VKD3D_CONFIG=dxr in the Environment Variables section under System options. Add VKD3D_CONFIG as the Key and dxr as the Value.

You should now have DLSS and Ray Tracing enabled.

Hmm… not sure why it would be different, but this is what I’m using for Control with GE-Proton in Steam:

VKD3D_FEATURE_LEVEL=12_1 %command% -dx12

Actually I had to switch to the default Proton 7.0-4 and change my launch options. For some reason GE-Proton 7-41 wasn’t working out so well.