DKMS not installing driver for additional installed Kernel (but works without it?)

Hi everyone! Hope this is a good place to ask, wasn’t quite sure.

Okay, so, strange issue here… I’ve installed Manjaro KDE some time ago, with 5.10 LTS kernel. Due to my rather ‘nontypical’ USB WiFi adapter, I had to install these drivers with DKMS. While installation went fine, when I tried to install a second kernel later (5.13), DKMS wouldn’t install the driver for it, so I created an issue on the github page of the project, here to be specific. It appears that if I install that driver manually, for both kernels, one by one, while running on those, installation goes just fine, but DKMS somehow still doesn’t want to work. Did someone in the past by any chance had a situation like that when DKMS wouldn’t want to install drivers for other kernels but manual installation went fine?

Any help appreciated, cheers!

Hello @dragon99919 :wink:

Why no just use the AUR package? It has the same source as you can see on the PKGBUILD.

AUR (en) - rtl8814au-dkms-git

pamac build rtl8814au-dkms-git

Did you install linux513-headers?


Tried that, the result is exactly the same. The driver installs properly on the Kernel I’m currently on, then after reboot when I try to install the second Kernel it gives exactly same error. Even the error and build log are exactly the same, 1:1.


Yep, I did. Actually Manjaro did it by itself when installing new Kernel (I guess it detected that I used headers with previous one so it was also necessary to get them for new one as well).


And what about this one?

AUR (en) - rtl88xxau-aircrack-dkms-git

pamac build rtl88xxau-aircrack-dkms-git