Divinity original sin only using ecores in this game? (Solved was now using all available threads. Used htop to resolve)

HI All,

New to linux and linux gaming. I found divinity original sin can be run native but for some reason it seems to focus on my CPU’s ecores. I get better performance when disabling ecores. Is there a simple fix for how the thread scheduler works?

It is no biggy as I can use proton and it performs better whilst using my p cores, but wondering if I am missing something obvious as a new user experimenting.

I am running the game from steam runtime and more info in the screenshot below:

Edit: Forgot to mention you can find my specs my clicking on my profile and I expect to be hitting 165fps for my screen refresh rate of 165hz which is easily obtained on proton. Wondering if there is some thread scheduler changes I can make like affinity on windows maybe. I dunno

  Kernel: 5.15.49-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=320b5aab-2cfa-4afb-adf0-ad664ace2fd6 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7D32 v: 1.0
    serial: <superuser required>
  Mobo: Micro-Star model: MAG Z690 TOMAHAWK WIFI DDR4 (MS-7D32) v: 1.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: 1.20
    date: 03/02/2022
  ID-1: hidpp_battery_0 charge: 96% condition: N/A volts: 4.1 min: N/A
    model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
    serial: <filter> status: discharging
  RAM: total: 15.42 GiB used: 8.28 GiB (53.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 12th Gen Intel Core i7-12700K bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 built: 2021 process: Intel 7 (10nm ESF)
    family: 6 model-id: 0x97 (151) stepping: 2 microcode: 0x1F
  Topology: cpus: 1x cores: 12 mt: 8 tpc: 2 st: 4 threads: 20 smt: enabled
    cache: L1: 1024 KiB desc: d-4x32 KiB, 8x48 KiB; i-8x32 KiB, 4x64 KiB
    L2: 12 MiB desc: 8x1.2 MiB, 1x2 MiB L3: 25 MiB desc: 1x25 MiB
  Speed (MHz): avg: 900 high: 1314 min/max: 800/5000:3800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 940 2: 802 3: 1113 4: 763
    5: 1113 6: 769 7: 1173 8: 789 9: 806 10: 800 11: 811 12: 800 13: 1314
    14: 988 15: 1014 16: 813 17: 800 18: 800 19: 800 20: 800 bogomips: 144440
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2 bts
    cat_l2 cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault
    cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq
    pconfig pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid
    rdrand rdseed rdt_a rdtscp rep_good sdbg sep serialize sha_ni smap smep
    smx split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall
    tm tm2 tme tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq
    umip vaes vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel AlderLake-S GT1 vendor: Micro-Star MSI driver: i915
    v: kernel ports: active: none
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3, HDMI-A-4 bus-ID: 00:02.0
    chip-ID: 8086:4680 class-ID: 0380
  Device-2: NVIDIA GA102 [GeForce RTX 3080 Ti] vendor: Micro-Star MSI
    driver: nvidia v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Ampere process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:2208 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: i915,nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-dpi: 93 s-size: 1397x393mm (55.00x15.47")
    s-diag: 1451mm (57.13")
  Monitor-1: DP-0 pos: primary,right res: 2560x1440 hz: 165 dpi: 93
    size: 697x392mm (27.44x15.43") diag: 800mm (31.48") modes: N/A
  Monitor-2: DP-2 pos: primary,left res: 2560x1440 hz: 144 dpi: 93
    size: 697x393mm (27.44x15.47") diag: 800mm (31.5") modes: N/A
  Monitor-3: HDMI-0 size-res: N/A modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 3080 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.48.07 direct render: Yes
  Device-1: Intel Alder Lake-S HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 1-10:8 chip-ID: 046d:0a78
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 class-ID: 0300
    serial: <filter> chip-ID: 8086:7ad0 class-ID: 0403
  Device-2: NVIDIA GA102 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aef class-ID: 0403
  Device-3: Logitech G560 Gaming Speaker type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Creative Sound Blaster X3 type: USB
    driver: cdc_acm,hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:17
    chip-ID: 041e:3264 class-ID: 0102 serial: <filter>
  Device-5: Micro Star USB Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-5:4 chip-ID: 0db0:b202
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.49-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Intel Alder Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:7af0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel Ethernet I225-V vendor: Micro-Star MSI driver: igc
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 04:00.0
    chip-ID: 8086:15f3 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:12 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 5.79 TiB used: 155.5 GiB (2.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:4 vendor: Samsung model: SSD 980 PRO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 3B2QGXA7 temp: 51.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Corsair model: Force MP510
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: ECFM22.5 temp: 44.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Crucial model: CT2000BX500SSD1
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 030 scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DM010-2EP102
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC43 scheme: GPT
  ID-5: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 870 QVO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
  ID-6: /dev/sdd maj-min: 8:48 type: USB vendor: SanDisk model: Ultra
    size: 114.61 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.37%) used: 155.5 GiB (8.5%)
    fs: ext4 dev: /dev/sdc2 maj-min: 8:34 label: N/A
    uuid: 320b5aab-2cfa-4afb-adf0-ad664ace2fd6
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sdc1 maj-min: 8:33 label: NO_LABEL
    uuid: 1215-3F76
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:5 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p2 maj-min: 259:6 size: 931.19 GiB fs: ntfs label: N/A
    uuid: 4AC2B047C2B03951
  ID-3: /dev/nvme0n1p3 maj-min: 259:7 size: 308 MiB fs: vfat
    label: NEW VOLUME uuid: 44EE-3B89
  ID-4: /dev/nvme1n1p1 maj-min: 259:1 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-5: /dev/nvme1n1p2 maj-min: 259:2 size: 223.25 GiB fs: ntfs label: N/A
    uuid: 56C01B89C01B6F0D
  ID-6: /dev/nvme1n1p3 maj-min: 259:3 size: 309 MiB fs: vfat
    label: NEW VOLUME uuid: 9EE2-6F60
  ID-7: /dev/sda1 maj-min: 8:1 size: 1.82 TiB fs: ntfs label: New Volume
    uuid: 42DED3DADED3C3F7
  ID-8: /dev/sdb1 maj-min: 8:17 size: 931.51 GiB fs: ntfs label: New Volume
    uuid: 8CDAE498DAE47FB6
  ID-9: /dev/sdd1 maj-min: 8:49 size: 3.41 GiB fs: iso9660
  ID-10: /dev/sdd2 maj-min: 8:50 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: 3ECF-2322
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:2 info: Micro Star MYSTIC LIGHT type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s
    power: 500mA chip-ID: 1462:7d32 class-ID: 0300 serial: <filter>
  Device-2: 1-4:17 info: Creative Sound Blaster X3
    type: HID,Abstract (modem),CDC-Data,Audio
    driver: cdc_acm,hid-generic,snd-usb-audio,usbhid interfaces: 7 rev: 2.0
    speed: 480 Mb/s power: 100mA chip-ID: 041e:3264 class-ID: 0102
    serial: <filter>
  Device-3: 1-5:4 info: Micro Star USB Audio type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 8 rev: 2.0
    speed: 480 Mb/s power: 100mA chip-ID: 0db0:b202 class-ID: 0300
  Device-4: 1-7:5 info: SanDisk Cruzer Blade type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.1 speed: 480 Mb/s power: 224mA
    chip-ID: 0781:5567 class-ID: 0806 serial: <filter>
  Device-5: 1-8:6 info: Logitech USB Receiver type: Mouse,Keyboard,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 98mA
    chip-ID: 046d:c541 class-ID: 0300
  Device-6: 1-9:7 info: Microsoft Controller type: <vendor specific>
    driver: xpad interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 500mA
    chip-ID: 045e:0b00 class-ID: ff00 serial: <filter>
  Device-7: 1-10:8 info: Logitech G560 Gaming Speaker type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s chip-ID: 046d:0a78 class-ID: 0300 serial: <filter>
  Hub-2: 1-12:9 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0608 class-ID: 0900
  Device-1: 1-12.1:11 info: Logitech PowerPlay Wireless Charging System
    type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid interfaces: 3
    rev: 2.0 speed: 12 Mb/s power: 498mA chip-ID: 046d:c53a class-ID: 0300
  Hub-3: 1-13:10 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0608 class-ID: 0900
  Device-1: 1-13.3:13 info: Corsair LCD Cap for Elite Capellix coolers
    type: HID driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 480 Mb/s
    power: 288mA chip-ID: 1b1c:0c33 class-ID: 0300 serial: <filter>
  Device-2: 1-13.4:14 info: Corsair iCUE Commander CORE type: HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 1b1c:0c1c class-ID: 0300 serial: <filter>
  Device-3: 1-14:12 info: Intel AX201 Bluetooth type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0026 class-ID: e001
  Hub-4: 2-0:1 info: Super-speed hub ports: 9 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-9:2 info: Elgato Systems GmbH Game Capture HD60 S
    type: <vendor specific> driver: N/A interfaces: 2 rev: 3.0 speed: 5 Gb/s
    power: 400mA chip-ID: 0fd9:0074 class-ID: ff00 serial: <filter>
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 56 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 33%
  Processes: 437 Uptime: 3h 20m wakeups: 9 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1
  Packages: pacman: 1263 lib: 352 flatpak: 0 Shell: Zsh v: 5.9 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.19

Share your system info in the post, don’t ask people to go dig for info, especially as these info are not fixed in time and will not be relevant later.

Also, natively it probably runs on OpenGL, and Windows version on DirectX (which will then be ‘translated’ with WINED3D for DX9-10-11 → OpenGL, with DXVK for DX11 → Vulkan and VKD3D for DX12 → Vulkan).
On my experience games run often better on Proton with DXVK (sometime VKD3D) with shader pre-cache enabled in Steam), as Linux version are often bad ports, or ports that didn’t receive lot of attention to issues.


Hello Omano,

I have made this change to the original post. I am not sure where you thought I was making people look. I only signed up today and by indicating to find my basic specs if anything made it extremely easier. That being said I more than accept that to be minimal knowledge maybe rather than making anyone dig :).

That being said you have taught me how to post useful information here and I thank you very much and will add the tutorial to my note app on manjaro.

Image below of digging:


I know exactly where you told people to look, I’m just saying no, don’t do that, share system info inside each support post you open, that is basic support rule. We can’t assume the profile information are correct, or relevant to the post (people have multiple computer for example), and even if you say they are correct, I already gave reasons why it is not the proper way to share these info)

No, follow the thread, and post actual real system information (and also never share text as images, this is really not appreciated on this kind of forum, it removes search results hidden inside an image, forces people to read the image (can’t search in it in the thread), and so on. Just follow that basic rule: share an image when it is relevant to share an image (showing visually an issue for example). Always share text as text (and following the thread, inside a CODE block, using the </> button or adding three backticks on new lines before and after the text to share so it is properly formatted).

Did you try another kernel, like 5.18, to see if it behaves differently?

Did you try to change the CPU governor to see if it changes the behavior (we don’t know how you start your game with Proton so things can be different)?

Any difference in the launch options in the game properties when you run the Windows version with Proton?

Yes I tried 5.18 real time which is the only one that worked for me. The other 5.18 and 5.19 do not work for me. Seems to fail when I first boot and it shows all my hardware such as usb devices and network adapter I think then crashed to the point I cannot even press control alt f2 to go to tty2 (if that is the right name) screen or do anything. I reinstalled Manjaro not knowing what I needed to do to fix (separate issue but other kernal forum posts seemed rather difficult for a new person when things go wrong).

I did not try to change CPU governor and maybe that is something I would be interested in. Proton Experimental is the only proton I tried in steam. Proton performs much better and very possibly for the reasons you mentioned in your first response which was fairly insightful and made me think it could just be the games fault it focuses on my ecores.

All my games just have the launch option “mangohud %command%”. That is when proton or not.

OK then MangoHud would not change anything regarding the CPU (but as you can see on your screenshot it tells you what the graphic API is, which is nice with all the other features).

I was thinking maybe you were using GameMode in your launch options and that could change the governor (and other things) that could change the performance in the end, but you don’t use it.

So maybe trying other governors wouldn’t change anything, but you never know you can try (list available governors with cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors and then you can change the governor with command sudo cpupower frequency-set -g GovernorNameHere).

//EDIT: another source of information for Steam games: https://www.protondb.com/app/435150

1 Like

Thanks to you giving me the terminology I already found some interesting cpu governor stuff all linked below. I would not be surprised if there is an article for everything gaming like this that I missed lol.

I will also try what you have just added. I would not be surprised if it results in nothing due to the nature of the issue, but you know what. I have learnt a whole lot lol

I found the solution! Images for the purpose of before and after to show it works and to close the topic.

So performance before my evil tweak:

and after :slight_smile: :

So what was the solution? Well I was trying to find something that does cpu affinity stuff like windows. After some googling I found “htop” which seems to work exactly like task manager in some aspects and comes with Manjaro Plasma which is great.

For anyone with this issue please see below simple guide for normies:

Open “htop” and click “cpu%” so that the highest system resource for cpu is shown at the top (in this case my game):

When you select “a” you find that it is using only threads 18 and 19 only. Here I changed everything to use every thread which I am sure is not the best option and I will probably reduce it, however it improved my fps. Hopefully this will help anyone in the future with cpu affinity issues in any particular game. I am guessing most people know how to do this, but I exist so :stuck_out_tongue: .

Edit: If you run in konsole “sudo htop” you can increase the priority which gives much higher frame consistency.

What I wonder now is what is the difference between running the game natively and from Proton, regarding the CPU assignment it does.


you may also want to look into GameMode (which you add the same way as mangohud in launch options), it can set some options on game launch and fall back on defaults on game exit.

I will definitely search that as the priority thing will surely be an annoyance. I know I tried rocket league earlier for a moment before optimisations and found it choppy on proton (only way you can play it these days apparently).

Well I am not quite sure on the best P threads (my brand new terminology for threads of the p cores). Like I believe too many threads is not well optimised for example as well. I will try figure it out as it would be interesting.

Probably because you need to build the shader cache if you don’t enable it in Steam as I already pointed out earlier.

The process can use all the assigned cores, that’s all. It doesn’t lower your performance assigning all the cores. I don’t believe you would notice a difference in performance assigning specific Pcores, instead of random/all Pcores.

I wish that was the problem but I believe it was turned on by default. I had the background one turned off though as that sounds bad.

Good knowledge to have! I know with like RPCS3 emulator it can only use so much due to how the program was designed (8 cores 16 threads) and the program itself will use the most optimided approach so I thought maybe this program may not do that and only be able to use so many of my threads. I will just use all the threads then.

It doesn’t sound bad, it processes game shaders in the background (when you’re not playing games) using a few cores, when needed (after a shader cache update, video drivers update, things like that), instead of using all cores when you start a game and its shader cache hasn’t been processed yet, and you need to wait between a few seconds to multiple minutes depending on the shader cache size. Obviously not only it is not bad, but it is actually good, especially for big games, because it is annoying to wait a long time when you just want to play or join a game. Definitely a must have for Proton in my opinion (and background processing of shaders is more convenient).

1 Like

Good to know! I will use that feature.

Now lets get some results on here.

Native linux with all threads and max priority

Proton before afinity and priority set. htop claimed it was using just 2 pcore threads however the results with mangohud show otherwise

With everything set to max for proton (threads used and priority)

I think it is fair that you can draw your own conclusions. All work excellently for me now and maybe I will find a native game that runs better than proton as a result of this method.

1 Like

Yep we can see native version has lower performance with OpenGL but you double performance forcing affinity to Pcores instead of Ecores. The Proton version is exactly the same with or without forcing core assignment (triple performance).

What game is that?

Divinity Original Sin Enhanced Edition

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.