Displayport monitor not detected


I’m trying to switch from Windows 10 to Manjaro for my desktop PC. I have a dual display configuration, one being connected with HDMI and the other one with DisplayPort. The problem I have is that my DP monitor isn’t recognized at all. I’m pretty sure it’s not a hardware problem because everything was working fine yesterday while I was using windows.

I tried to go through some of the posts on the forum but most of them were about laptops and hybrid display systems. Seemed to me that my problem wouldn’t be related to this.
I also tried to start the computer with just the DP monitor connected but it didn’t change a thing.

I run a AMD Ryzen 5 3600X and a GeForce RTX 2080 SUPER. I installed the 6.6.30 kernel in order to have, what seemed to be, the latest LTS release.
I don’t know if that would change something but I’m using the KDE Plasma desktop environment.

Here are the outputs of inxi -Fxxz :

  Kernel: 6.6.30-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A wm: kwin_x11 dm: SDDM
    Distro: Manjaro base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7B86 v: 4.0
    serial: <superuser required>
  Mobo: Micro-Star model: B450-A PRO MAX (MS-7B86) v: 4.0
    serial: <superuser required> UEFI: American Megatrends v: M.60
    date: 04/18/2020
  ID-1: hidpp_battery_0 charge: 27% condition: N/A volts: 3.7 min: N/A
    model: Logitech G Pro Wireless Gaming Mouse serial: <filter>
    status: discharging
  Info: 6-core model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2
    rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 32 MiB
  Speed (MHz): avg: 2320 high: 3599 min/max: 2200/4409 boost: enabled cores:
    1: 3599 2: 2057 3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2055
    10: 2353 11: 2200 12: 2386 bogomips: 91230
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU104 [GeForce RTX 2080 SUPER] vendor: Micro-Star MSI
    driver: nvidia v: 550.78 arch: Turing pcie: speed: 8 GT/s lanes: 16 ports:
    active: none off: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 26:00.0
    chip-ID: 10de:1e81
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 101
  Monitor-1: HDMI-0 res: 1920x1080 dpi: 102 diag: 547mm (21.54")
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 2 drv: swrast
    gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 2080
  API: Vulkan v: 1.3.279 surfaces: xcb,xlib device: 0 type: discrete-gpu
    driver: nvidia device-ID: 10de:1e81
  Device-1: NVIDIA TU104 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 26:00.1 chip-ID: 10de:10f8
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 28:00.4 chip-ID: 1022:1487
  Device-3: Logitech PRO X 2 LIGHTSPEED
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 bus-ID: 5-2.1:3 chip-ID: 046d:0af7
  API: ALSA v: k6.6.30-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 2.73 TiB used: 9.46 GiB (0.3%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 31.9 C
  ID-2: /dev/sda vendor: Seagate model: ST2000DX001-1NS164 size: 1.82 TiB
    speed: 6.0 Gb/s serial: <filter>
  ID-1: / size: 906.86 GiB used: 9.46 GiB (1.0%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 296 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3
  System Temperatures: cpu: 51.9 C mobo: N/A gpu: nvidia temp: 31 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 24%
  Memory: total: 32 GiB available: 31.29 GiB used: 2.86 GiB (9.1%)
  Processes: 314 Power: uptime: 17m wakeups: 0 Init: systemd v: 255
    default: graphical
  Packages: pm: pacman pkgs: 1148 Compilers: N/A Shell: Zsh v: 5.9
    running-in: konsole inxi: 3.3.34

xrandr :

DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+  59.94    50.00  
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)

and mhwd :

> 0000:26:00.0 (0300:10de:1e81) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2024.05.03               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
           video-linux            2024.05.06                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Thanks in advance !

Did you upgrade an existing installation?

Most do this - but the switch from Plasma 5 to Plasma 6 may have left some incompatible configurations.

You appear to have booted xorg - please try with Wayland.

If you have not already done so, the first thing is switch the DP port perhaps the event required to trigger the system to find the display.

It is not possible to provide a one-stop answer - you will have to go over some troubleshooting steps. Please see NVIDIA/Troubleshooting - ArchWiki for more info as this is likely to apply for Manjaro as well.

Thank you for your help !

No it was a clean install using the “plasma desktop” official image.
I tried switching the DP port and it did not change anything. Neither the screen nor the system seemed to detect anything.

I’ll try to get wayland working and come back to give feedback.

Switching to wayland didn’t change anything.

I even had a weirder behaviour. At first the second screen was detected but not recognized. I couldn’t set any property nor have anything to be displayed on it. The settings menu just showed me that an “unknown” display was detected.

I tried to solve this following other posts and reading the docs but, being part of the newb team, I messed things up and now the screen isn’t detected at all …

I found a hdmi-DP cable and tried connecting one of my screen with this cable while the other one is connecting through a HDMI cable. And it works, I have both my screen detected and displaying properly.

This kinda solves my problem but not entirely as I still can’t get my main screen to work through DP.

Shall I set @linux-aarhus answer as the solution ?